Summenbildung in einer Matrix mit mehreren Kriterien

28/12/2007 - 15:47 von U2K | Report spam
Hallo,

ich möchte gerne die Spalte "D" summieren, wenn das Datum der Spalte G
zwischen dem "1.12.2007" und dem "31.12.2007" ist und die Spalte "I" den
Wert "160050" enthàlt.

Habe schon ein paar sachen auprobiert und weiß jetzt nicht mehr weiter.

Hier ein paar Versuche von mir:

=SUMME(WENN(Time_unit!G2:G12>=Tabelle3!B3;WENN(Time_unit!G2:G12>=Tabelle3!B4;WENN(Time_unit!I2:I12=Tabelle3!B2;Time_unit!D2:D12;0))))

oder

=SUMMENPRODUKT((Time_unit!$G$2:G12>=Tabelle3!$B$3)*(Time_unit!$G$2:G12<=Tabelle3!$B$4)*(Time_unit!$I$2:I12=Tabelle3!$B$2)*(Time_unit!$D$2:D12))

Da ist irgendwie der wurm drin.

Kann mir hierbei vielleicht jemand Helfen?

Besten Dank

Viele Grüße

Sven
 

Lesen sie die antworten

#1 Lorenz Hölscher
28/12/2007 - 16:02 | Warnen spam
Hallo Sven,

ein voller Realname wàre auch schön...

Du schreibst leider nicht, welcher Wurm da drin ist, gibt es eine
Fehlermeldung, ist das Ergebnis falsch?? Du hast hoffentlich daran
gedacht, eine solche Matrix-Formel mit Strg+Umschalt+Eingabe zu
beenden? (siehe Tipp "Matrix-Formeln erweitern Excels Fàhigkeiten
enorm!" unter http://www.cls-software.de/cls_soft...rmeln.aspx)

Wenn ich mal so raten dürfte, steht das im Text genannte Datum in
Tabelle3!B3. Dann setzt das doch mal absolut (Tabelle3!$B$3),
vielleicht hilft das.

Es gibt übrigens auch die alternative
Schreibweise ...Wenn(Und(xxx;yyy);aaa;bbb)... mit xxx als erste
Bedingung, yyy als zweite Bedingung und aaa/bbb als den jeweils
gewünschten Ergebnissen.

tschö, Lorenz

Ähnliche fragen