Summenformel durch Einfügen einer Zeile erweitern

14/09/2007 - 13:55 von Peter Schneider | Report spam
Hallo zusammen,

ich habe in Excel in einer Zelle eine Formel. =SUMME(A1:A5).

Wenn ich jetzt z.B. in Zeile A3 klicken und sage neue Zeile einfügen,
dann wird die Formel automatisch auf =SUMME(A1:A6) erweitert. So soll
es auch sein.

Wenn ich jedoch auf die Zeile, in der auch die Formel steht klicke und
sage neue Zeile einfügen, dann wird zwar eine neue Zeile oberhalb der
Zelle in der die Formel steht eingefügt, aber die Formel NICHT
erweitert. Es bleibt dann bei =SUMME(A1:A5). Obwohl es auch bis A6
gehen sollte.

Ist das jemandem auch schonmal aufgefallen? Was kann ich da machen?

mfg
peter schneider
 

Lesen sie die antworten

#1 Thomas Ramel
14/09/2007 - 14:10 | Warnen spam
Grüezi Peter

"Peter Schneider" schrieb:

ich habe in Excel in einer Zelle eine Formel. =SUMME(A1:A5).

Wenn ich jetzt z.B. in Zeile A3 klicken und sage neue Zeile einfügen,
dann wird die Formel automatisch auf =SUMME(A1:A6) erweitert. So soll
es auch sein.

Wenn ich jedoch auf die Zeile, in der auch die Formel steht klicke und
sage neue Zeile einfügen, dann wird zwar eine neue Zeile oberhalb der
Zelle in der die Formel steht eingefügt, aber die Formel NICHT
erweitert. Es bleibt dann bei =SUMME(A1:A5). Obwohl es auch bis A6
gehen sollte.

Ist das jemandem auch schonmal aufgefallen? Was kann ich da machen?



Ja, dieses Verhalten ist normal und Du kannst es auch nicht umstellen ohne
mit VBA zu arbeiten.

Füge also neue Zeilen nur *innerhalb* der Datenzeieln ein.

Wenn Du xl2003 oder höher verwendest, dann kannst Du den Bereich als 'Liste'
definieren.
Dort kannst Du in der letzten Zeile die Summe darstellen lassen und auch neu
in die Liste eingefügte Zeilen werden automatisch berücksichtigt.

Mit freundlichen Grüssen

Thomas Ramel (@Web-Interface)
- MVP für Microsoft-Excel -

[Win XP Pro SP-2 / xl2003]

Ähnliche fragen