Summenprodukt läuft mal wieder nicht

15/10/2007 - 10:25 von Walter | Report spam
Hallo,

ich möchte die Summe der Sicherheitsbestànde addieren. Da jedoch nicht
alle Artikel eingerechnet werden dürfen, sondern nur die eines
bestimmten Bereiches, wollte ich es mit der Funktion "Summenprodukt"
zur Lösung kommen. Ich habe folgende Formel angegeben:
"=SUMMENPRODUKT((AT5:AT1000>0)*($J$5:$J$1000))"
In der Spalte AT stehen immer dann Umrechnungswerte (um auf
Fertigungseinheiten zu kommen), wenn es Artikel dieses Bereiches
betrifft. In Spalte J steht immer der Sicherheitsbestand (in
Verkaufseinheiten).
So habe ich beispielsweise in Zeile 5, 6 und 7 jeweils in Spalte AT
die Werte 0, 1,12 und 0 stehen und in Spalte J 300, 200 und 0. Als
Ergebnis erhalte ich für das Beispiel 200. Es müssten jedoch 224
angezeigt werden.
Was mache ich falsch????

Gruß
Walter
 

Lesen sie die antworten

#1 Alexander Wolff
15/10/2007 - 11:20 | Warnen spam
"=SUMMENPRODUKT((AT5:AT1000>0)*($J$5:$J$1000))"
In der Spalte AT stehen immer dann Umrechnungswerte (um auf
Fertigungseinheiten zu kommen), wenn es Artikel dieses Bereiches
betrifft. In Spalte J steht immer der Sicherheitsbestand (in
Verkaufseinheiten).
So habe ich beispielsweise in Zeile 5, 6 und 7 jeweils in Spalte AT
die Werte 0, 1,12 und 0 stehen und in Spalte J 300, 200 und 0. Als
Ergebnis erhalte ich für das Beispiel 200. Es müssten jedoch 224
angezeigt werden.




Statt
=SUMMENPRODUKT((AT5:AT1000>0)*($J$5:$J$1000))
schreibe
=SUMMENPRODUKT(--($AT$5:$AT$1000>0);$AT$5:$AT$1000;$J$5:$J$1000)

Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen