SUMMENPRODUKT mit Spaltenzahl?

15/06/2013 - 20:59 von Peter Schuerer | Report spam
Hallo Zusammen,

XL 2002.

Ich muss aus einer Datenbank ein universelles Diagramm erstellen.
Im Diagramm gibt es ein "Dropdown" für die einzelnen Positionen, die in
Tabelle1 errechnet werden sollen.
Die ausgewàhlte Position wird in Tabelle1 in $B$74 eingetragen.
Die Formel:
=SUMMENPRODUKT((DBProd!$T$3:$T$6000=$B76)*(DBProd!$B$3:$B$6000=C$74);(DBProd!$E$3:$E$6000))
berechnet die Werte aus E3:E6000.
In Spalte T steht der Monat als Text, Spalte B die Gruppe (1 oder 2).

Ich muss jetzt den Teil der Formel (oben) so àndern, das die Formel die
ausgewàhlte Position berechnet:
=SUMMENPRODUKT((DBProd!$T$3:$T$6000=$B76)*(DBProd!$B$3:$B$6000=C$74);(DBProd!Spalte$B$74$3:Spalte$B$74$6000))
Die Formel sollte eigentlich das Summenprodukt aus der Spalte bilden,
die in $B$74 als Zahl steht.
Nach 2 Stunden kriege ich es leider immer noch nicht hin, bitte dringend
um Hilfe.

MfG
Peter
 

Lesen sie die antworten

#1 Claus Busch
15/06/2013 - 21:26 | Warnen spam
Hallo Peter,

Am Sat, 15 Jun 2013 20:59:41 +0200 schrieb Peter Schuerer:

Ich muss jetzt den Teil der Formel (oben) so àndern, das die Formel die
ausgewàhlte Position berechnet:
=SUMMENPRODUKT((DBProd!$T$3:$T$6000=$B76)*(DBProd!$B$3:$B$6000=C$74);(DBProd!Spalte$B$74$3:Spalte$B$74$6000))
Die Formel sollte eigentlich das Summenprodukt aus der Spalte bilden,
die in $B$74 als Zahl steht.



ich hoffe, dass ich dich richtig verstanden habe. Probiere es mal so:
=SUMMENPRODUKT(--(DBProd!$T$3:$T$6000=$B76);--(DBProd!$B$3:$B$6000=C$74);(INDIREKT("DBProd!"&ADRESSE(3;Tabelle1!$B$74)&":"&ADRESSE(6000;Tabelle1!$B$74))))
Die Formel wàre einfacher, wenn du für die gewünschte Spalte den
Buchstaben eintragen würdest.


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen