Summenprodukt Monat

27/08/2013 - 07:22 von Peter Schuerer | Report spam
Hallo Zusammen (Claus),

XL2002.

Gegeben ist eine Tabelle, in Spalte A steht das Datum (TT.MM.JJJJ),
Spalte U der Monat aus Spalte A als Text und Spalte Q der Wert.
In Spalte U ("Monat") kommt jeder Monat fortlaufend, aber in
unterschiedlicher Anzahl vor.
Also 10mal Januar, 7mal Februar, 23mal Màrz, 4mal April, 64mal Mai .

Jetzt soll aus Spalte Q die Summe, nach Anfangsmonat und Endmonat,
gebildet werden.
Der Anwender gibt in X4 den Anfangsmonat und in X5 den Endmonat ein.

Meine Formel über Spalte U (Monat in X4, X5 als Text):
=SUMMENPRODUKT(($U$3:$U$6000>=$X$4)*($U$3:$U$6000<=$X$5);($Q$3:$Q$6000))

Meine Formel über Spalte A (Monat in X4, X5 als Zahl):
=SUMMENPRODUKT(($A$3:$A$6000>=Monat($X$4))*($A$3:$A$6000<=Monat($X$5));($Q$3:$Q$6000))

Nichts rechnet richtig. Ich habe ; und * in allen Variationen probiert.
Entweder kommt #Wert oder 0.
Wie kann ich das lösen, wo liegt der Fehler?

Danke und Gruß
Peter
 

Lesen sie die antworten

#1 Claus Busch
27/08/2013 - 08:06 | Warnen spam
Hallo Peter,

Am Tue, 27 Aug 2013 07:22:07 +0200 schrieb Peter Schuerer:

Gegeben ist eine Tabelle, in Spalte A steht das Datum (TT.MM.JJJJ),
Spalte U der Monat aus Spalte A als Text und Spalte Q der Wert.
In Spalte U ("Monat") kommt jeder Monat fortlaufend, aber in
unterschiedlicher Anzahl vor.
Also 10mal Januar, 7mal Februar, 23mal Màrz, 4mal April, 64mal Mai .

Jetzt soll aus Spalte Q die Summe, nach Anfangsmonat und Endmonat,
gebildet werden.
Der Anwender gibt in X4 den Anfangsmonat und in X5 den Endmonat ein.



wenn in X4 und X5 die Monatnummern stehen, dann:
=SUMMENPRODUKT((--(MONAT(A3:A6000)>=$X$4)-(MONAT(A3:A6000)>$X$5))*Q3:Q6000)


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen