Forums Neueste Beiträge
 

Summenprodukt

27/08/2008 - 16:57 von Gerhard Reil | Report spam
Hallo NG,

ich komme bei der Umsetzung von SUMMENPRODUKT in einem Fall einfach nicht
weiter -
vielleicht kann mir "geholfen werden"?

In der Zeile 10 Spalte C steht ein Text, in dem u.a. das erste Wort
"PLANUNG" steht.
in der Zeile 10 Spalte i steht ein Netto-Wert z.B. 100,00
in der Zeile 10 Spalte J steht: =Wenn(i10="";"";19) > also der Prozentsatz
19 %
in der Zeile 10 Spalte K steht: =Wenn(i10<>"";Runden((i10/100*j10;2);"") >
Betrag Umsatzsteuer
in der Zeile 10 Spalte L steht:=Wenn(i10<>"";i10+k10;"") > Brutto-Betrag

Bei einer Auswertung über SUMMENPRODUKT funktioniert dies bei dem Nettowert
aus i10 (Netto-Wert) mit der Formel
=SUMMENPRODUKT(((LINKS(C1:C20;7)="PLANUNG")*(i1:i20))
einwandfrei. Bei der Auswertung der Formel
=SUMMENPRODUKT(((LINKS(C1:C20;7)="PLANUNG")*(k1:k20))
bezogen auf die Umsatzsteuerwerte in der Spalte K und der Bruttosummen in
der Spalte L ist das
Ergebnis immer #WERT!

Leider habe ich hier noch keine Lösung für die Änderung der
Summenprodukt-Formel gefunden - außer ich àndere
die Zellenformel in z.B. Wenn(i10<>"";Runden((i1o/100*j10;2);0) ab.

Gruß
Gerhard Reil
Excel 2003
WIN XP
 

Lesen sie die antworten

#1 Claus Busch
27/08/2008 - 17:24 | Warnen spam
Hallo Gerhard,

Am Wed, 27 Aug 2008 16:57:57 +0200 schrieb Gerhard Reil:


Bei einer Auswertung über SUMMENPRODUKT funktioniert dies bei dem Nettowert
aus i10 (Netto-Wert) mit der Formel
=SUMMENPRODUKT(((LINKS(C1:C20;7)="PLANUNG")*(i1:i20))
einwandfrei. Bei der Auswertung der Formel
=SUMMENPRODUKT(((LINKS(C1:C20;7)="PLANUNG")*(k1:k20))
bezogen auf die Umsatzsteuerwerte in der Spalte K und der Bruttosummen in
der Spalte L ist das
Ergebnis immer #WERT!



bei mir làuft das problemlos. Du hast in deiner Summenprodukt-Formel
entweder vorne eine Klammer zuviel oder hinten eine zu wenig.
Entweder:
=SUMMENPRODUKT((LINKS(C1:C20;7)="PLANUNG")*(K1:K20))
oder
=SUMMENPRODUKT(((LINKS(C1:C20;7)="PLANUNG")*(K1:K20)))

Den Fehlerwert #WERT! bekommst du, wenn irgendwo in deinen Spalten I:L
im entsprechenden Bereich Texte stehen. Kontrolliere daher mal das
Format.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen