SUMMENPRODUKT und Jahr

03/01/2009 - 15:51 von Merlin Morgenstern | Report spam
Hallo zusammen,

ich versuche über SPprod daten zusammen zu fassen. leider klappt das nur
für ein jahr. jan 08 wird mit jan 09 verrechnet. hat jemand ne idee wie
man das verbessern kann?

=SUMMENPRODUKT((MONAT('Ausgaben -
Tag'!$A$2:$A$990)=MONAT(U$1))*('Ausgaben -
Tag'!$C$2:$C$990=$A39)*('Ausgaben - Tag'!$B$2:$B$990))

Vielen Dank für jeden Tipp,

Merlin
 

Lesen sie die antworten

#1 Hajo_Zi
03/01/2009 - 16:01 | Warnen spam
Hallo Merlin,

Summe für ein Monat
leer wird als Januar interpretiert / Excel bzw. Billy spinnen
um dieses auszuschließen:
=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*B1:B100)
hier werden die Werte aus B addiert wenn in A der Monat Januar steht (egal,
welches Jahr)
Mit Jahreseingrenzung auf 2003 so:
=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*(JAHR( A1:A100) 03)*B1:B100)
von WF

Gruß Hajo
MVP für Microsoft Excel
Betriebssystem Vista Ultimate SP1 und Excel Version2007 SP1
http://Hajo-Excel.de/



"Merlin Morgenstern" wrote:

Hallo zusammen,

ich versuche über SPprod daten zusammen zu fassen. leider klappt das nur
für ein jahr. jan 08 wird mit jan 09 verrechnet. hat jemand ne idee wie
man das verbessern kann?

=SUMMENPRODUKT((MONAT('Ausgaben -
Tag'!$A$2:$A$990)=MONAT(U$1))*('Ausgaben -
Tag'!$C$2:$C$990=$A39)*('Ausgaben - Tag'!$B$2:$B$990))

Vielen Dank für jeden Tipp,

Merlin

Ähnliche fragen