SummeWenn bringt falsches Ergebnis!

20/01/2010 - 14:30 von Jasi | Report spam
Hallo Gruppe!

Ich habe folgendes Problem mit der Funktion SUMMEWENN:
Das Ergebnis stimmt nicht wenn ich nach den Kriterien suche die in meinen
Beispiel angeführt werden:

Spalte
A B
2.1 1
2.2 2
2.3 3
2.4 4
2.5 5
2.6 6
2.7 7
2.8 8
2.9 9
2.10 10
2.11 11
2.1.1 12
2.1.2 13
2.1.3 14
2.1.4 15
2.1.5 16
2.1.6 17
2.1.7 18
2.1.8 19
2.1.9 20
2.1.10 21
2.1.11 22

Verwende ich die Formel:
=SUMMEWENN(A1:A22;"2.1";B1:B22)
wird mir als Ergebnis 22 angezeigt und nicht 1 wie erwartet.

Durch testen bin ich draufgekommen das Excel in diesen Fall leider nicht NUR
2.1 zum Berechnen verwendet sondern auch 2.1.10 mitrechnet. Deshalb erscheint
das Ergeniss 22.

Wieso rechnet Excel in diesen Fall falsch? Es werden komischerweise ja 2.1.1
u. 2.1.11 nicht mitgerechnet sondern nur 2.1.10? Kann ich das vermeiden und
exakt nur nach 2.1 suchen?

Ich verwende auf meinen Rechner Windows XP und Office 2003. Das beschriebene
Verhalten konnte auf verschiedenen Rechnern und auch mit Office 2000
nachgestellt werden.

Vielen Dank im voraus,
Jasi
 

Lesen sie die antworten

#1 Peter Schleif
20/01/2010 - 14:49 | Warnen spam
Jasi schrieb am 20.01.2010 14:30 Uhr:

Wieso rechnet Excel in diesen Fall falsch? Es werden komischerweise ja 2.1.1
u. 2.1.11 nicht mitgerechnet sondern nur 2.1.10?



Das liegt daran, dass Excel die Werte als Datum interpretiert. Der "2.1"
wird als 2.Februar des aktuellen Jahres interpretiert; genau wie
"2.1.10". Hingegen ist "2.1.11" der 2.Februar nàchsten Jahres.

Peter

Ähnliche fragen