SummeWenn Problem

27/03/2009 - 23:57 von Horst Hoffmann | Report spam
Hallo,

ich möchte in einer Spalte Daten addieren, wenn in der Nachbarspalte ein
bestimmter Text steht. Das geht mit SummeWenn.
Ist es auch möglich, die Funktion anzuwenden, wenn man nur ein Zeichen
(Anfangszeichen) des Textes nutzen will?
Beispiel:

44 a1
55 b2
66 a3
77 b4
99 a4
21 b5

In der linken Spalte sollen z.B. alle Werte summiert werden, deren
Nachbarspalte mit a anfàngt.

Ich habe versucht in die Summewenn-Kriterien so etwas wie

=SUMMEWENN(A6:A14;"a"=(links(B6:B14;1);A6:A14)

einzugeben, aber das funktioniert nicht. Kann man überhaupt eine
Excelfunktion in den Kriterienbereich einbinden?

Viele Grüße und Dank im Voraus

Horst Hoffmann
 

Lesen sie die antworten

#1 Klaus Blaschke
28/03/2009 - 06:04 | Warnen spam
Am 27.03.2009 23:57:09 schrieb Horst Hoffmann:

ich möchte in einer Spalte Daten addieren, wenn in der Nachbarspalte ein
bestimmter Text steht. Das geht mit SummeWenn.
Ist es auch möglich, die Funktion anzuwenden, wenn man nur ein Zeichen
(Anfangszeichen) des Textes nutzen will?
Beispiel:
44 a1
55 b2
66 a3
77 b4
99 a4
21 b5
In der linken Spalte sollen z.B. alle Werte summiert werden, deren
Nachbarspalte mit a anfàngt.
Ich habe versucht in die Summewenn-Kriterien so etwas wie
=SUMMEWENN(A6:A14;"a"=(links(B6:B14;1);A6:A14)
einzugeben, aber das funktioniert nicht. Kann man überhaupt eine
Excelfunktion in den Kriterienbereich einbinden?



Hallo Horst

=SUMMENPRODUKT(("a"=LINKS(B6:B14)=WAHR)*(A6:A14))

Gruß
Klaus

Ähnliche fragen