Forums Neueste Beiträge
 

SummeWennS + Datentyp Datum pruefen auf groesser/kleiner/gleich

04/05/2010 - 12:11 von Stefan Nowak | Report spam
Geehrte Damen und Herren!

Ich führe eine Liste meiner Haushaltsausgaben (siehe Arbeitsblatt "l"
Liste) und würde aus jenen Listendaten gern auf Arbeitsblatt "u" eine
Übersicht über Monate / Quartale / Jahre aufbereiten. Ich benötige
Hilfe bei der Erstellung einer Formel, im Beispiel gekennzeichnet als
Formel-X, denn ich weiss nicht wie man in Excel eine
Größer/Kleiner/Gleich Prüfung mit dem Datentyp Datum bewerkstelligt.
Danke!



Arbeitsblatt "l" Liste

A Datum | B Beschreibung | C Kategorie | D Preis

01.03.10 | Pflaster | ges | 2,49
12.03.10 | Lebensmittel Billa | hh | 27,38
28.03.10 | Süsses Tankstelle | imb | 5,86
07.04.10 | Grüne Jeans Benetton | kle | 79,95
12.04.10 | Bier 3,5 + Schnitzel 8,7 + 1,8 Trinkgeld | aus | 14,00
20.04.10 | 2 x Handseife Bipa | hh | 5,98



Arbeitsblatt "u" Übersicht über Monate / Quartale / Jahre

A und B bestimmen den Zeitraum.
Spalte C und folgende sind Kategorien.
Formel-X erstelle ich einmal, und ziehe sie dann per fill-right auf
sàmtliche Kategorie-Spalten, und per fill-down auf alle benötigten
Zeilen. (Kenne deren deutsche Bezeichnung nicht, Sie wissen was ich
meine)

A Von inkl | B Bis exkl | C hh | D imb | E aus | F kle

01.03.2010 | 01.04.2010 | Formel-X | <-- Formel-X per fill-right -->
01.04.2010 | 01.05.2010 | ^
01.05.2010 | 01.06.2010 | | ... Formel-X per fill-down ...
01.06.2010 | 01.07.2010 | v



Für Formel-X benötige ich Ihre Hilfe!
Grundsàtzlich stell ich sie mir so vor:

Pseudo-Code:

=SUMMEWENNS(l!D2:D10000; l!A2:A10000; ">=$A2"; l!A2:A10000; "<$B2";
l!C2:C10000; "=C$1")

Erklàrung:

=SUMMEWENNS(Zellen der Spalte Preise der Liste; Zellen der Spalte Datum
der Liste; GrößerGleich als Zelle Datum A der Übersicht; Zellen der
Spalte Datum der Liste; Kleiner als Datum B der Übersicht; Zellen der
Spalte Kategorie der Liste; Entspricht der Zelle in der
TabellenKopfZeile)
 

Lesen sie die antworten

#1 Erdmut Siebert
04/05/2010 - 13:29 | Warnen spam
"Stefan Nowak" schrieb im Newsbeitrag
news:hrorsk$893$
Geehrte Damen und Herren!

Ich führe eine Liste meiner Haushaltsausgaben (siehe Arbeitsblatt "l"
Liste) und würde aus jenen Listendaten gern auf Arbeitsblatt "u" eine
Übersicht über Monate / Quartale / Jahre aufbereiten. Ich benötige Hilfe
bei der Erstellung einer Formel, im Beispiel gekennzeichnet als Formel-X,
denn ich weiss nicht wie man in Excel eine Größer/Kleiner/Gleich Prüfung
mit dem Datentyp Datum bewerkstelligt. Danke!



Arbeitsblatt "l" Liste

A Datum | B Beschreibung | C Kategorie | D Preis

01.03.10 | Pflaster | ges | 2,49
12.03.10 | Lebensmittel Billa | hh | 27,38
28.03.10 | Süsses Tankstelle | imb | 5,86
07.04.10 | Grüne Jeans Benetton | kle | 79,95
12.04.10 | Bier 3,5 + Schnitzel 8,7 + 1,8 Trinkgeld | aus | 14,00
20.04.10 | 2 x Handseife Bipa | hh | 5,98



Arbeitsblatt "u" Übersicht über Monate / Quartale / Jahre

A und B bestimmen den Zeitraum.
Spalte C und folgende sind Kategorien.
Formel-X erstelle ich einmal, und ziehe sie dann per fill-right auf
sàmtliche Kategorie-Spalten, und per fill-down auf alle benötigten Zeilen.
(Kenne deren deutsche Bezeichnung nicht, Sie wissen was ich meine)

A Von inkl | B Bis exkl | C hh | D imb | E aus | F kle

01.03.2010 | 01.04.2010 | Formel-X | <-- Formel-X per fill-right -->
01.04.2010 | 01.05.2010 | ^
01.05.2010 | 01.06.2010 | | ... Formel-X per fill-down ...
01.06.2010 | 01.07.2010 | v



Für Formel-X benötige ich Ihre Hilfe!
Grundsàtzlich stell ich sie mir so vor:

Pseudo-Code:

=SUMMEWENNS(l!D2:D10000; l!A2:A10000; ">=$A2"; l!A2:A10000; "<$B2";
l!C2:C10000; "=C$1")

Erklàrung:

=SUMMEWENNS(Zellen der Spalte Preise der Liste; Zellen der Spalte Datum
der Liste; GrößerGleich als Zelle Datum A der Übersicht; Zellen der Spalte
Datum der Liste; Kleiner als Datum B der Übersicht; Zellen der Spalte
Kategorie der Liste; Entspricht der Zelle in der TabellenKopfZeile)




Hallo Stefan,

Du bist hier in der falschen newsgroup, das gehört nach Excel!
Ich führe auch ein Haushaltsbuch, das mache ich aber mit Pivot, Da kann ich
alle Sortierungen z.B nach Tagen, Monaten, oder Quartalen usw vornehmen .
Ich arbeite Mit Excel 2007. Wenn Du Interesse hast, kann ich Dir per PM ein
Beispiel zusenden.

Servus
Erdmut

Ähnliche fragen