Summierung aufgrund einer Schlüsselnummer

14/05/2008 - 20:50 von Arthur | Report spam
Guten Abend,
ich habe in einer Excel-Datei mehrere Tabellenblàtter. Jede Tabellen
beinhaltet Werte für ein Jahr.
In einer Spalte des jeweiligen Tabellenblattes sind Betràge, einer anderen
eine Schlüsselnummer für den Klienten. Manchmal hat Klient 1 einen Betrag in
einem Jahr, manchmal nicht und somit kann ich auch keine feste Zeilenzahl
vorgeben.
Nun möchte ich in einer Gesamttabelle
die Schlüsselnummer ausgeben und
die dazugehörigen Betràge der verschiedenen Jahre (Tabellenblàtter).
Gibt es eine Suchfunktion die mir diese Werte in einer Tabelle vereinigt.
Vielen Dank für die Hilfe
Arthur
 

Lesen sie die antworten

#1 Robert Gelbmann
14/05/2008 - 22:34 | Warnen spam
Hallo Arthur!

"Arthur" schrieb ...
Guten Abend,
ich habe in einer Excel-Datei mehrere Tabellenblàtter. Jede
Tabellen
beinhaltet Werte für ein Jahr.
In einer Spalte des jeweiligen Tabellenblattes sind Betràge, einer
anderen
eine Schlüsselnummer für den Klienten. Manchmal hat Klient 1 einen
Betrag in
einem Jahr, manchmal nicht und somit kann ich auch keine feste
Zeilenzahl
vorgeben.
Nun möchte ich in einer Gesamttabelle
die Schlüsselnummer ausgeben und
die dazugehörigen Betràge der verschiedenen Jahre
(Tabellenblàtter).
Gibt es eine Suchfunktion die mir diese Werte in einer Tabelle
vereinigt.



Wenn ich dich recht verstanden habe, könntest du in deiner
Gesamttabelle zunàchst eine Spalte mit allen vorkommenden
Schlüsselnummern erstellen (zB in A2:A100).

Danach kannst du zB in der Spalte B die Summe für das erste Jahr
(vom Blatt 1) ermitteln.
Angenommen dein Blatt heißt Blatt1 und die Schlüsselnummern stehen
dort in B2:D123 und die Betràge in C2:C123, dann würde die Formel in
B2 lauten:

=SUMMEWENN(Blatt1!$D$2:$D$123;$A2;Blatt1!$C$2:$C$123)

Analog dazu kannst du dir dann die Formeln für die weiteren Jahre
(zB in den folgenden Spalten) "basteln".

Etwas vereinfacht wird das Ganze, wenn du für die Bereiche jeweils
Namen definierst (Einfügen / Namen / Definieren).


Eine andere Alternative könnte für dich die Konsoldierung (Menü
Daten) sein. Auch dabei wàren Namen von Vorteil.


In der Hoffnung geholfen zu haben, verbleibe ich mit einem leisen


Servus aus Wien,
-Robert Gelbmann-

The world is quiet here.

Ähnliche fragen