SuSE 10.3 - ATI-Treiber und 'fglrx' mit aktivem Xgl - Desktop Effects funktionieren nicht mehr

30/10/2008 - 11:01 von Markus Egartner | Report spam
Hallo erstmal,

habe heute (30.10.08) meinen ATI-Treiber (X1600) und den dazugehörigen
fglrx für X11 upzudaten. Gesagt getan lief alles problemlos, bis ich
rebootet habe.

die beiden Pakete lauten:
ati-fglrxG01-kmp-default (vom ATI Respostory)
x11-video-fglrxG01 (vom openSuSE Respostory 'xgl')

Sooooooo, nun kann ich aber die "Desktop - Effects" unter KDE nicht mehr
verwendenheißt:

Sobald ich diese axtivieren möchte verschiebt er mir die Dinge am
Desktop so, daß ich fast nichts mehr erkennen konnte und kann.

Ein nochmaliges durchziehen des Procederes unter 'init 3' von:
ldconfig
aticonfig --initial --input=/etc/X11/xorg.conf
sax2 -r -m 0=fglrx

(und dem nachjustieren in der xorg.conf mit anschließendem 'reboot')

brachte nicht das gewünschte Ergebnis.

Fazit: Xorg funktioniert wie gehabt Xgl funktioniert auch bloß aber
nicht mit den aktivierten Desktop Effect (in Folge auch das
fusion-package)

Frage:
1.) hat jemand nen Tipp wie ich das fixen kann damit ich die
Desktop-Effects wieder verwenden kann?

2.)wenn nicht 1.) dann gibt's ne möglichkeit über yast wieder auf den
vorigen treiber bzw. altes fglrx zurückzugreifen?

Gruß
-Markus
 

Lesen sie die antworten

#1 Christian Mosewitzsch
31/10/2008 - 09:09 | Warnen spam
Hi
probiers mal ohne Xgl. das làuft hier mit einer radeon 9600 super

hier ein Auszug aus der Xorg:

Section "Device"
BusID "1:0:0"
Driver "fglrx"
Identifier "Device[0]"
Option "XAANoOffscreenPixmaps" "true"
Option "Capabilities" "000000000"
Option "OpenGLOverlay" "off"
Option "dri" "true"
Option "FSAAScale" "0"
Option "FSAAEnable" "off"
Option "VideoOverlay" "on"
Option "GARTSize" "32"
Screen 0
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "enable"
Option "DAMAGE" "true"
EndSection


gruss Christian

Markus Egartner wrote:

Hallo erstmal,

habe heute (30.10.08) meinen ATI-Treiber (X1600) und den dazugehörigen
fglrx für X11 upzudaten. Gesagt getan lief alles problemlos, bis ich
rebootet habe.

die beiden Pakete lauten:
ati-fglrxG01-kmp-default (vom ATI Respostory)
x11-video-fglrxG01 (vom openSuSE Respostory 'xgl')

Sooooooo, nun kann ich aber die "Desktop - Effects" unter KDE nicht mehr
verwendenheißt:

Sobald ich diese axtivieren möchte verschiebt er mir die Dinge am
Desktop so, daß ich fast nichts mehr erkennen konnte und kann.

Ein nochmaliges durchziehen des Procederes unter 'init 3' von:
ldconfig
aticonfig --initial --input=/etc/X11/xorg.conf
sax2 -r -m 0=fglrx

(und dem nachjustieren in der xorg.conf mit anschließendem 'reboot')

brachte nicht das gewünschte Ergebnis.

Fazit: Xorg funktioniert wie gehabt Xgl funktioniert auch bloß aber
nicht mit den aktivierten Desktop Effect (in Folge auch das
fusion-package)

Frage:
1.) hat jemand nen Tipp wie ich das fixen kann damit ich die
Desktop-Effects wieder verwenden kann?

2.)wenn nicht 1.) dann gibt's ne möglichkeit über yast wieder auf den
vorigen treiber bzw. altes fglrx zurückzugreifen?

Gruß
-Markus

Ähnliche fragen