Forums Neueste Beiträge
 

SuSE Leap 42.1 installieren

06/08/2016 - 03:18 von Alexander Goetzenstein | Report spam
Hallo,
auf einen neuen Laptop möchte ich Leap 42.1 installieren. Bislang hatte
mich das nicht vor größere Schwierigkeiten gestellt, aber dieser Laptop
ist für mich der erste Rechner mit UEFI. Das, so vermute ich, verursacht
mir einige Knoten.

Vorgegangen bin ich folgendermaßen: im BIOS-Setup habe ich bei
"UEFI/Legacy Boot" eingestellt: [Both] und [Legacy First], CSM Support
auf [YES]. Das heißt dann auch, dass Secure Boot disabled ist. Nachdem
ich (in einem anderen Laptop) ein Image von der jungfràulichen SSD
angefertigt habe, boote ich von einem USB-Stick das Installationmedium
(der Laptop hat kein optisches Laufwerk). Bei der Installation entferne
ich die Wiederherstellungspartition (/dev/sda4) und verkleinere die
Windows7-Partition (/dev/sda3) etwas. Den Rest der Partitionierung
überlasse ich den Vorgaben der Installationsroutine; lediglich grub2
installiere ich neben in /dev/sda6 auch in den MBR -so hatte ich es
zuvor beim alten BIOS auch gemacht. Die Installation làuft durch, bis
der erste Reboot ansteht -und dieser führt dann direkt zu Windows, von
grub2 ist nichts zu sehen.

Bei der anschließenden Fehlersuche ist mir aufgefallen, dass zwar der
SuSE-Stick bootet, aber Knoppix nicht mehr (was vor der Installation
problemlos klappte). Von der Platte will immer nur Windows booten, egal
was mir eingefallen ist. Witzig ist auch, dass der Start von der Platte
des alten Laptops im neuen Laptop funktioniert (zumindest im Legacy
Mode); dort hatte ich die Installation ja noch mit dem traditionellen
BIOS vorgenommen.

Jetzt habe ich lange genug im Nebel gestochert. Wer klàrt mich über
meine Fehlverstàndnisse auf und sagt mir, wie es richtig geht?


Gruß
Alex
 

Lesen sie die antworten

#1 Alexander Goetzenstein
06/08/2016 - 05:16 | Warnen spam
Hallo,
ich habe noch ein wenig weiter gestochert, Secure Boot eingeschaltet und
damit UEFI Only eingeschaltet. Damit ließ sich Leap jetzt installieren,
und es startet auch von der Festplatte, wenn auch mit einigen
Unterschieden. Einer davon, wie WiFi-Karte, ist mir so wichtig, dass ich
dafür einen neuen Thread eröffnet habe. Ich stochere weiter, würde mich
aber über erhellende und beschleunigende Tipps weiterhin freuen.


Am 06.08.2016 um 03:18 schrieb Alexander Goetzenstein:
Hallo,
auf einen neuen Laptop möchte ich Leap 42.1 installieren. Bislang hatte
mich das nicht vor größere Schwierigkeiten gestellt, aber dieser Laptop
ist für mich der erste Rechner mit UEFI. Das, so vermute ich, verursacht
mir einige Knoten.

Vorgegangen bin ich folgendermaßen: im BIOS-Setup habe ich bei
"UEFI/Legacy Boot" eingestellt: [Both] und [Legacy First], CSM Support
auf [YES]. Das heißt dann auch, dass Secure Boot disabled ist. Nachdem
ich (in einem anderen Laptop) ein Image von der jungfràulichen SSD
angefertigt habe, boote ich von einem USB-Stick das Installationmedium
(der Laptop hat kein optisches Laufwerk). Bei der Installation entferne
ich die Wiederherstellungspartition (/dev/sda4) und verkleinere die
Windows7-Partition (/dev/sda3) etwas. Den Rest der Partitionierung
überlasse ich den Vorgaben der Installationsroutine; lediglich grub2
installiere ich neben in /dev/sda6 auch in den MBR -so hatte ich es
zuvor beim alten BIOS auch gemacht. Die Installation làuft durch, bis
der erste Reboot ansteht -und dieser führt dann direkt zu Windows, von
grub2 ist nichts zu sehen.

Bei der anschließenden Fehlersuche ist mir aufgefallen, dass zwar der
SuSE-Stick bootet, aber Knoppix nicht mehr (was vor der Installation
problemlos klappte). Von der Platte will immer nur Windows booten, egal
was mir eingefallen ist. Witzig ist auch, dass der Start von der Platte
des alten Laptops im neuen Laptop funktioniert (zumindest im Legacy
Mode); dort hatte ich die Installation ja noch mit dem traditionellen
BIOS vorgenommen.

Jetzt habe ich lange genug im Nebel gestochert. Wer klàrt mich über
meine Fehlverstàndnisse auf und sagt mir, wie es richtig geht?





Gruß
Alex

Ähnliche fragen