SVERWEIS mit benanntem Bereich #BEZUG!

15/10/2008 - 18:46 von FRANZ LUWEIN | Report spam
Hallo alle,

ich benötige mal wieder neuere Hilfe.

Etwas stimmt in der Formel nicht, doch was?

=SVERWEIS(A1;INDIREKT(B1;C1;D1);2;Falsch) ergibt #BEZUG!

Erklàrung zu Suchmatrix:
B1&C1&D1 = aus drei Texten zusammengesetzter Name für einen benannten
Bereich im Workbook.

Der benannten Bereich/Suchmatrix (variabel) liegt auf anderen
Tabellenblàttern und besteht immer aus A1:B50 und C1:D50.

Wie könnte die Formel aussehen, dass sie funktioniert?
Ich kann die benannten Bereiche nicht untereinander (z.B. A1:B100)
schreiben!

Besten Dank im Voraus

Franz Luwein
 

Lesen sie die antworten

#1 Alexander Wolff
15/10/2008 - 19:02 | Warnen spam
Die Tastatur von FRANZ LUWEIN wurde wie folgt gedrückt:
=SVERWEIS(A1;INDIREKT(B1;C1;D1);2;Falsch) ergibt #BEZUG!

Erklàrung zu Suchmatrix:
B1&C1&D1 = aus drei Texten zusammengesetzter Name für einen benannten
Bereich im Workbook.



Warum dann B1;C1;D1 statt B1&C1&D1? Ansonsten funktioniert es.

Der benannten Bereich/Suchmatrix (variabel) liegt auf anderen
Tabellenblàttern und besteht immer aus A1:B50 und C1:D50.

Wie könnte die Formel aussehen, dass sie funktioniert?
Ich kann die benannten Bereiche nicht untereinander (z.B. A1:B100)
schreiben!



Halt! Wenn Du die Bereiche mit SVERWEIS derart virtuell untereinander
referenzieren können möchtest, hilft Dir noch nicht einmal
http://excelformeln.de/formeln.html?welcher#3, weil es nur in die 3.
Dimension "durchzustechen" in der Lage ist, jedoch nicht wie bislang
gleichzeitig die Zeilen ablàuft.

http://excelformeln.de/formeln.html?gruppe=3 könnte aber evtl. andere
Anregungen liefern.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen