sverweis mit ermitteltem Bereich

29/03/2009 - 11:59 von uwedj | Report spam
Hallo Experten,

der SVERWEIS soll in eimem ermitteltem Bereich suchen.

ich ermittel aus Zàhlenwenn () + Zeile() den sich ergebenden Bereich.

Nun versuche ich über INDIREKT die Spalte auf dem Blatt "hilfs" in A1 und
die ermittelte Zeile in L11 sowie bis ":" hilfs B1 und der Endzeile M11
suchen zu lassen und scheiter :-(

=SVERWEIS(F3;INDIREKT(hilfs!A1&hilfs!L11&":"&hilfs!B1&hilfs!M11);2;)

wenn ich manuell den bereich deklariere dann klappt das einwandfrei.

geht der SVERWEIS mit INDIREKT nicht ?

Hillfeeeeeee, was mache ich falsch.

Vielen Dank
Uwe Schröder
 

Lesen sie die antworten

#1 Alexander Wolff
29/03/2009 - 12:38 | Warnen spam
Nun versuche ich über INDIREKT die Spalte auf dem Blatt "hilfs" in A1 und
die ermittelte Zeile in L11 sowie bis ":" hilfs B1 und der Endzeile M11
suchen zu lassen und scheiter :-(

=SVERWEIS(F3;INDIREKT(hilfs!A1&hilfs!L11&":"&hilfs!B1&hilfs!M11);2;)



A1 und B1 müßten dann aber Spalten-Buchstaben enthalten; wenn Du Zahlen
hast, geht es so nicht (hab ich aber jetzt auch mit Buchstaben nicht
verifiziert!).

Guck Dir mal
=SVERWEIS(F3;INDEX(A:Z;1;1):INDEX(A:Z;100;2);2;)
an. Darin bringst Du Deine Zellen wie folgt unter:

(A:B; könnte reichen ...
;L11 ;M11
;A1 ;B1
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen