SVERWEIS mit variabel auswählbarer Matrix

08/08/2013 - 18:57 von matthiaswalz | Report spam
Hallo,

ich habe fünf gleiche Tabellen, denen ich jeweils einen NAMEN (Szenario1, Szenario2, ...) gegeben habe. In der ersten Spalte steht die Kontonummer, in den folgenden Spalten die Monate 1 bis 12. Die Werte sind dann die Betràge des einzelnen Kontos im jeweiligen Monat.

Jan Feb Màr
Konto 100 5 3 5
Konto 200 10 8 4

In einer separaten Tabelle möchte ich nur per SVERWEIS auf die Werte der Szenarien zugreifen. Zur Auswahl des Szenarios habe ich ein Drop-Down Feld in Zelle B1.

Mein SVERWEIS lautet: SVERWEIS("Konto 100";B1;2;falsch)

Das Problem ist, dass der Wert aus dem Feld B1 nicht als NAMEN der Matrix erkannt wird, sondern als Text. Dadurch erhalte ich keinen Wert. Habe ich z.B. in B1 das Szenario1 ausgewàhlt, dann erhalte ich bei der Formelauswertung:

=SVERWEIS("Konto 100";"Szenario1";2;falsch)

Das Szeanrio1 wird in Anführungszeichen gesetzt und dadurch nicht als Namen der Matrix erkannt. Mit der Formel SVERWEIS("Konto 100";Szenario1;2;falsch) funktioniert es.

Gibt es eine Möglichkeit hierfür?

Danke,
Matthias
 

Lesen sie die antworten

#1 Claus Busch
08/08/2013 - 19:17 | Warnen spam
Hallo Matthias,

Am Thu, 8 Aug 2013 09:57:20 -0700 (PDT) schrieb :

Jan Feb Màr
Konto 100 5 3 5
Konto 200 10 8 4



probiere es so:
=SVERWEIS("Konto 100";INDIREKT(B1);2;0)


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen