SVERWEIS mit zwei Suchkriterien und variablem Ergebnisvektor

04/09/2009 - 11:36 von Alexander Früh | Report spam
Hallo NG,

aus einer Tabelle möchte ich abhàngig von den Werten in Spalte 1 und 2 mir
den Wert aus der letzten benutzten Zelle dieser Zeile ausgeben lassen.
Ich habe schon etwas gestöbert und auch einiges gefunden, ich bekomm's
allerdings nicht zusammengesetzt.
Meine beiden Einzellösungen habe ich unter
http://www.excelformeln.de/formeln.html?welcherH
und
http://www.excelformeln.de/formeln.html?welcher0
gefunden.
Allerdings schaffe ich es nicht, beides zu verwurschteln. Irgendwie stehe
ich auf dem Schlauch.
In der zweiten Lösung muss ich ja die Spalte "C:C" durch mein "Ergebnis" aus
der ersten Lösung ersetzen. Aber genau da liegt der Knackpunkt.
Das Ergebnis aus der ersten Lösung ist die Spaltennummer, also eine Zahl.
Aus der muss ich jetzt die Spalte als Range generieren.
Wer kann mir helfen?
Vielen Dank.

Gruß Alex
 

Lesen sie die antworten

#1 Alexander Wolff
04/09/2009 - 12:06 | Warnen spam
Die Tastatur von Alexander Früh wurde wie folgt gedrückt:
Hallo NG,

aus einer Tabelle möchte ich abhàngig von den Werten in Spalte 1 und
2 mir den Wert aus der letzten benutzten Zelle dieser Zeile ausgeben
lassen.
Ich habe schon etwas gestöbert und auch einiges gefunden, ich bekomm's
allerdings nicht zusammengesetzt.
Meine beiden Einzellösungen habe ich unter
http://www.excelformeln.de/formeln.html?welcherH
und
http://www.excelformeln.de/formeln.html?welcher0
gefunden.
Allerdings schaffe ich es nicht, beides zu verwurschteln. Irgendwie
stehe ich auf dem Schlauch.
In der zweiten Lösung muss ich ja die Spalte "C:C" durch mein
"Ergebnis" aus der ersten Lösung ersetzen. Aber genau da liegt der
Knackpunkt.
Das Ergebnis aus der ersten Lösung ist die Spaltennummer, also eine
Zahl. Aus der muss ich jetzt die Spalte als Range generieren.




Da die letzte Spalte gefragt ist, setze ich die Formel in Spalte A. Deine
auszuwertenden Daten beginnen alle in B.

A B C D E F G
w e
d f Bis
s d Ab
a s Zu
y x Von
w g

5
Zu


A9: =WENN(INDEX(B:B;VERGLEICH("s";C:C;0))="a";VERGLEICH("a";B:B;0))
A10: =VERWEIS(2;1/(INDIREKT(A9&":"&A9)<>"");INDIREKT(A9&":"&A9))

ist Dein gesuchtes Ergebnis (Frank-Kabel-Formel). Ich habe Deine Links
verwendet.

A9 kann auch in A10 eingesetzt werden, wird dann aber 4mal statt einmal
gerechnet.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen