SVERWEIS nur bis 3000 Zeilen? Finde den Fehler nicht

31/08/2010 - 13:49 von Alex Busam | Report spam
Hallo,

hab eine Excel-Datei seit Jahren am Laufen. Die importiert aus einer
Oracle-DB den Inhalt einer Abfrage und schreib die aufs Tabellelblatt
DATENBANK:
6150 FRÜHLINGSROLLE GROSS 9,90
6151 FRÜHLINGSROLLE MINI 9,90
6152 SPINATTALER 9,90

Die Daten werden dann je nach Einsatzort ausgewàhlt in einem weiteren
Tabellenblatt dargestellt. Dazu tràgt der Anwender nur in Spalte 1 die
Nummer an, der Rest wird aus dem Blatt DATENBANK mittels SVERWEIS geholt:
Bsp:
A7: hier steht die Nummer 6150
B7: =WENN(A7>0;SVERWEIS(A7;DATENBANK!$A:$C;2;FALSCH);"")
C7: =WENN(A7>0;SVERWEIS(A7;DATENBANK!$A:$C;3;FALSCH);"")

Es funktioniert wunderbar bis zum Verweis von Daten in den ersten 3000
Zeilen. Werden Nummern abgefragt aus Zeilen >3000 erscheint #NV. Es geht
um Excel 2000. In der Hilfe fand ich irgendwo, dass der Bereich bis
65xxx Zeilen haben dürfte. Aus wenn ich den Bereich fest definiere:
=WENN(A7>0;SVERWEIS(A7;DATENBANK!$A$2:$C$5000;2;FALSCH);"")
funktioniert das nicht.
Ich versteh das Verhalten nicht, da auch ein:
=WENN(A7>0;SVERWEIS(A7;DATENBANK!$A$3000:$C$5000;2;FALSCH);"")
zum gleichen Fehler führt. Hier wàre der Bereich ja nur 2000 Zeilen
groß. Trotzdem kommt nur ein #NV

Kann mir jemand weiterhelfen? Ich schick auch gern das File per EMail
oder wie auch immer zu.

Viele Grüße
alex
 

Lesen sie die antworten

#1 Jörg Burzeja
31/08/2010 - 19:29 | Warnen spam
Am 31.08.2010 13:49, schrieb Alex Busam:

hab eine Excel-Datei seit Jahren am Laufen. Die importiert aus einer
Oracle-DB den Inhalt einer Abfrage und schreib die aufs Tabellelblatt
DATENBANK:
6150 FRÜHLINGSROLLE GROSS 9,90
6151 FRÜHLINGSROLLE MINI 9,90
6152 SPINATTALER 9,90

Die Daten werden dann je nach Einsatzort ausgewàhlt in einem weiteren
Tabellenblatt dargestellt. Dazu tràgt der Anwender nur in Spalte 1 die
Nummer an, der Rest wird aus dem Blatt DATENBANK mittels SVERWEIS geholt:
Bsp:
A7: hier steht die Nummer 6150
B7: =WENN(A7>0;SVERWEIS(A7;DATENBANK!$A:$C;2;FALSCH);"")
C7: =WENN(A7>0;SVERWEIS(A7;DATENBANK!$A:$C;3;FALSCH);"")

Es funktioniert wunderbar bis zum Verweis von Daten in den ersten 3000
Zeilen. Werden Nummern abgefragt aus Zeilen >3000 erscheint #NV. Es geht
um Excel 2000. In der Hilfe fand ich irgendwo, dass der Bereich bis
65xxx Zeilen haben dürfte. Aus wenn ich den Bereich fest definiere:
=WENN(A7>0;SVERWEIS(A7;DATENBANK!$A$2:$C$5000;2;FALSCH);"")
funktioniert das nicht.
Ich versteh das Verhalten nicht, da auch ein:
=WENN(A7>0;SVERWEIS(A7;DATENBANK!$A$3000:$C$5000;2;FALSCH);"")
zum gleichen Fehler führt. Hier wàre der Bereich ja nur 2000 Zeilen
groß. Trotzdem kommt nur ein #NV

Kann mir jemand weiterhelfen? Ich schick auch gern das File per EMail
oder wie auch immer zu.



Wenn da keine Geheimnisse drinstehen, kannst Du die hier hochladen, und
danach den Link mitteilen - http://www.file-upload.net/

Dann kann man das schneller nachvollziehen.

Excel 2000 wird verwendet, oder? Hast Du schon mal selbst mit einer
Version ab 2003 ausprobiert?


Viele Grüsse
Jörg

++ Where Do you want to go tomorrow? ++
++ http://schneegans.de/usenet/microsoft-umzug/ ++

Ähnliche fragen