SVERWEIS

08/04/2010 - 11:06 von Thomas M | Report spam
Hallo,

ich habe eine Frage zu den SVerweisen.
Ich habe eine SVerweis der in einer Grundtabelle nach einem definierten Text
sucht (z.B. "Reisekosten" und als Rückgabewert das Textfeld einer 2. Spalte
liefert zB. "Personalkosten"). So weit so gut. Jetzt möchte ich am Ende der
Grundtabelle ein "Rest"-Feld haben. Also immer wenn das Textfeld (in dem
Beispiel hier "Reisekosten") nicht gefunden wird, soll also das letzte
Feld - bzw. die 2. Spalte des letzten Feldes als Rückgabewert genommen
werden.
Wie muß dann der SVerweis dazu aussehen ? Geht das überhaupt?

Gruß
Thomas M
 

Lesen sie die antworten

#1 Thomas Ramel
08/04/2010 - 19:32 | Warnen spam
Grüezi Thomas

Thomas M schrieb am 08.04.2010

Ich habe eine SVerweis der in einer Grundtabelle nach einem definierten Text
sucht (z.B. "Reisekosten" und als Rückgabewert das Textfeld einer 2. Spalte
liefert zB. "Personalkosten"). So weit so gut. Jetzt möchte ich am Ende der
Grundtabelle ein "Rest"-Feld haben. Also immer wenn das Textfeld (in dem
Beispiel hier "Reisekosten") nicht gefunden wird, soll also das letzte
Feld - bzw. die 2. Spalte des letzten Feldes als Rückgabewert genommen
werden.
Wie muß dann der SVerweis dazu aussehen ? Geht das überhaupt?



Nein, das ist IMO direkt über den SVERWEIS() nicht möglich.

Baue daher eine Zàhlfunktion ein, die prüft ob der gesuchte Wert in der
ersten Spalte der Matrix enthalten ist und reagiere denn entsprechend:

=WENN(ZÄHLENWENN($E$1:$E$8;A1)=0;"Rest";SVERWEIS(A1;$E$1:$F$8;2;0))


Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Vista Ultimate SP-1 / xl2007 SP-1]

Ähnliche fragen