SVERWEIS: unverstaendliche Resultate

18/04/2008 - 21:11 von Knappe | Report spam
Hallo!

Das Problem mit den "verbotenen" Namen fuer Named Ranges habe ich loesen
koennen (auch ohne Uebersetzungstabelle mit Hilfe eines anderen Kniffes).
Allerdings steh ich jetzt vor dem naechsten Problem:

Die folgenden Eintraege stehen in A1 bis B8

E_2a 1
E_2b 2
E_1a 3
E_1b 4
A_1a 5
A_1b 6
O 7
B 8

A11 enthaelt ein Dropdownfeld mit Gueltigkeitsbereich =$A$1:$A$8

A15 enthaelt: =SVERWEIS(A11;A1:B8;2)

Allerdings bekomme ich nicht die Zahlen in A15 angezeigt, die zu den
ausgewaehlten Sachen passen.
E_2a ergibt 6
E_2b ergibt 6
E_1a ergibt #NV
E_1b ergibt 4
A_1a ergibt #NV
A_1b ergibt #NV
O ergibt 7
B ergibt #NV

Wo steckt jetzt hier der Fehler? Das Tabellenblat ist absolut jungfreulich
und die Version 2003 SP3 deutsch.

Testweise habe ich mal fuer die A-spalte mit E, F, G, H, I, J, O und K
verwendet. Dann klappt es bis O, aber bei K wird 6 angezeigt.


Ciao , Frank.
 

Lesen sie die antworten

#1 Claus Busch
18/04/2008 - 21:20 | Warnen spam
Hallo Frank,

Am 18 Apr 2008 19:11:01 GMT schrieb Frank Knappe:


Das Problem mit den "verbotenen" Namen fuer Named Ranges habe ich loesen
koennen (auch ohne Uebersetzungstabelle mit Hilfe eines anderen Kniffes).
Allerdings steh ich jetzt vor dem naechsten Problem:

Die folgenden Eintraege stehen in A1 bis B8

E_2a 1
E_2b 2
E_1a 3
E_1b 4
A_1a 5
A_1b 6
O 7
B 8

A11 enthaelt ein Dropdownfeld mit Gueltigkeitsbereich =$A$1:$A$8

A15 enthaelt: =SVERWEIS(A11;A1:B8;2)



du hast den Parameter für den Bereich_Vereis in der Sverweis-Formel nicht
drin. Probiere es so:
=SVERWEIS(A11;A1:B8;2;0)
0 für exakte Übereinstimmung, 1 für den nàchst kleineren Wert.

Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen