sverweis in VBA

03/06/2009 - 23:11 von Thom | Report spam
Hallo liebe NG

Ich steh mal wieder am Berg und komm nicht weiter. Ich habe eine Sverweis
Formel die wie folgt aussieht

=SVERWEIS(B2;'Kummuliert-fr2'!$B$2:$C$60000;2)

diese Formel ist in D2 bis D60000. Spalte C "Kummulliert-fr2" enthàlt die
Bezeichnung der Artikelnummer in B.

Bei einigen Eintràgen (eigentlich sehr vielen) ist das Ergebnis in D #nv.
Das Suchkriterium in B ist jedoch identisch wie in "kummuliert-fr2" Spalte B

Beispiel für Spalte B

0.1113.401

01202-5060-8
00555700
00557015-1
M0124913


auch stimmen manchmal die Bezeichnungen (D) Ausgelesen werden nicht überein
mit der Nummer in B
Mach ich was falsch, gibts evtl. ein VBA Script das besser arbeitet?

Danke im Voraus für mögliche Tipps

Gruss Thom
 

Lesen sie die antworten

#1 Beverly
04/06/2009 - 08:45 | Warnen spam
Hi Thom,

vielleicht hilft

=SVERWEIS(B2;'Kummuliert-fr2'!$B$2:$C$60000;2;0)

Durch den Zusatz 0 wird eine genaue Übereinstimmung erzwungen.

Bis spàter,
Karin
http://beverly.excelhost.de/


"Thom" wrote:

Hallo liebe NG

Ich steh mal wieder am Berg und komm nicht weiter. Ich habe eine Sverweis
Formel die wie folgt aussieht

=SVERWEIS(B2;'Kummuliert-fr2'!$B$2:$C$60000;2)

diese Formel ist in D2 bis D60000. Spalte C "Kummulliert-fr2" enthàlt die
Bezeichnung der Artikelnummer in B.

Bei einigen Eintràgen (eigentlich sehr vielen) ist das Ergebnis in D #nv.
Das Suchkriterium in B ist jedoch identisch wie in "kummuliert-fr2" Spalte B

Beispiel für Spalte B

0.1113.401

01202-5060-8
00555700
00557015-1
M0124913


auch stimmen manchmal die Bezeichnungen (D) Ausgelesen werden nicht überein
mit der Nummer in B
Mach ich was falsch, gibts evtl. ein VBA Script das besser arbeitet?

Danke im Voraus für mögliche Tipps

Gruss Thom




Ähnliche fragen