SVERWEIS in VBA

31/03/2009 - 13:04 von Tobias | Report spam
Hallo Zusammen,
ich habe ein Problem in der SVERWEIS Funktion den Zellwert hochzuzàhlen.

For i = 3 To 10
Range("c" & i).FormulaLocal = "=SVERWEIS(Range("A" &
_i);[RWA.xls]Sheet1!$A$3:$B$45;2;FALSCH)"
Next i

Gibt immer eine Fehlermeldung für den Range Befehl in der Funktion

Wenn ich statt Range("A"&i") in der Funktion einfach den Wert der
ersten Zelle A3 eintrage funktioniert alles wunderbar, allerdings mit
dem Vergleich nur für a3. Die Funktion soll aber den Vergleich mittels
der Schleife für alle Zellen von a3 bis a10 durchführen.

Wie kann ich den Wert hochzàhlen?

Vielen Dank
Tobias
 

Lesen sie die antworten

#1 Martin Worm
31/03/2009 - 14:10 | Warnen spam
Am Tue, 31 Mar 2009 13:04:36 +0200,schrieb Tobias:

hallo,


Hallo Zusammen,
ich habe ein Problem in der SVERWEIS Funktion den Zellwert hochzuzàhlen.

For i = 3 To 10
Range("c" & i).FormulaLocal = "=SVERWEIS(Range("A" &
_i);[RWA.xls]Sheet1!$A$3:$B$45;2;FALSCH)"
Next i

Gibt immer eine Fehlermeldung für den Range Befehl in der Funktion

Wenn ich statt Range("A"&i") in der Funktion einfach den Wert der
ersten Zelle A3 eintrage funktioniert alles wunderbar, allerdings mit
dem Vergleich nur für a3. Die Funktion soll aber den Vergleich mittels
der Schleife für alle Zellen von a3 bis a10 durchführen.

Wie kann ich den Wert hochzàhlen?



Range("c" & I).FormulaLocal = "=SVERWEIS(A" & I & _
";[RWA.xls]Sheet1!$A$3:$B$45;2;FALSCH)"

Range ist für VBA für XL reicht A3 ;-)


mit freundlichen Grüßen

Martin Worm
benutze XL 2000 und Win XP SpX

Ähnliche fragen