System Monitor PerfMon - SQL-Performance Counters nicht speicherba

15/11/2007 - 10:11 von M.H | Report spam
Hallo,

ich habe an beiden von 2 SQL-Servern das Problem, dass sich die
SQL-Performance Counter zwar mit dem System Monitor Perfmon zwar auswàhlen
und anzeigen lassen, aber wenn ich den Perfmon als sql.msc abspeichere und
danach wieder öffne sàmtliche SQL-Leistungsindikatoren weg sind und nur noch
die vom System da sind.

Das gleiche mit der Leistungsprotokollierung die ich starten möchte.
Dort kommt, wenn ich den Vorgang starte, im Ereignisprotokoll:

Ereignistyp: Warnung
Ereignisquelle: SysmonLog
Ereigniskategorie: Keine
Ereigniskennung: 2028
Beschreibung:
Der Dienst konnte den Leistungsindikator "\\SERVER\SQLServer:General
Statistics\User Connections" nicht zur Protokollierung oder Warnung "sql"
hinzufügen. Diese Protokollierung oder Warnung wird weiterhin ausgeführt,
aber es werden keine Daten für den Leistungsindikator gesammelt. Der
zurückgegebene Fehlercode ist: Das angegebene Objekt wurde nicht im System
gefunden.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter
http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: b8 0b 00 c0

Wer hat da einen Rat für mich?
Er kann die Indikatoren ja auch anzeigen. Also sind sie ja da :-/


Gruß
 

Lesen sie die antworten

#1 Christoph Muthmann
16/11/2007 - 08:34 | Warnen spam
M.H wrote:
Hallo,

ich habe an beiden von 2 SQL-Servern das Problem, dass sich die
SQL-Performance Counter zwar mit dem System Monitor Perfmon zwar
auswàhlen und anzeigen lassen, aber wenn ich den Perfmon als sql.msc
abspeichere und danach wieder öffne sàmtliche
SQL-Leistungsindikatoren weg sind und nur noch die vom System da
sind.

Das gleiche mit der Leistungsprotokollierung die ich starten möchte.
Dort kommt, wenn ich den Vorgang starte, im Ereignisprotokoll:

Ereignistyp: Warnung
Ereignisquelle: SysmonLog
Ereigniskategorie: Keine
Ereigniskennung: 2028
Beschreibung:
Der Dienst konnte den Leistungsindikator "\\SERVER\SQLServer:General
Statistics\User Connections" nicht zur Protokollierung oder Warnung
"sql" hinzufügen. Diese Protokollierung oder Warnung wird weiterhin
ausgeführt, aber es werden keine Daten für den Leistungsindikator
gesammelt. Der zurückgegebene Fehlercode ist: Das angegebene Objekt
wurde nicht im System gefunden.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie
unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: b8 0b 00 c0

Wer hat da einen Rat für mich?
Er kann die Indikatoren ja auch anzeigen. Also sind sie ja da :-/



Hallo!
Realnamen sind hier gerne gesehen!

Ich würde folgendes probieren:
- unlodctr mssqlserver und danach lodctr sqlctr.ini

- http://support.microsoft.com/?kbid00956
How to manually rebuild Performance Counter Library values

HTH!

Einen schönen Tag noch,
Christoph
(Please post ALL replies to the newsgroup only unless indicated
otherwise)

Ähnliche fragen