[systemd] [Debian] NFS-Mounten beim Booten klappt nicht immer

08/12/2014 - 15:53 von E. Braun | Report spam
Mal wieder stolpere ich über ein Problem, welches ausgestorben schien…

Gegeben ist ein frisch installiertes normales Debian Testing mit
systemd 215. Ein paar Verzeichnisse sollen beim Booten über NFS
eingebunden werden, was aber nicht immer gelingt.

Die entsprechenden Eintràge in /etc/fstab:

prost:/usr/local /usr/local nfs4 auto,nolock,tcp,noatime,nodev,async 0 0
prost:/home /home nfs4 auto,nolock,tcp,nodev,async 0 0
nfs01:/export/data08/matlab /data/matlab nfs4 auto,async 0 0


Die Meldungen über journalctl – egal, ob das Mounten gelang – lauten:

Networking[511]: Configuring network interfaces...done.
[…]
mount[582]: mount.nfs4: Failed to resolve server nfs01: Name or service not known
mount[583]: mount.nfs4: Failed to resolve server prost: No address associated with hostname
mount[585]: mount.nfs4: Failed to resolve server prost: No address associated with hostname
systemd[1]: Dependency failed for Remote File Systems.
systemd[1]: data-matlab.mount mount process exited, code=exited status2
systemd[1]: Failed to mount /data/matlab.
systemd[1]: Unit data-matlab.mount entered failed state.
systemd[1]: home.mount mount process exited, code=exited status2
systemd[1]: Failed to mount /home.
systemd[1]: Unit home.mount entered failed state.
systemd[1]: usr-local.mount mount process exited, code=exited status2
systemd[1]: Failed to mount /usr/local.
systemd[1]: Unit usr-local.mount entered failed state.

Hat jemand eine Idee, wie erreicht werden kann, daß die NFS-Mounts immer gelingen?
 

Lesen sie die antworten

#1 Tim Ritberg
08/12/2014 - 16:52 | Warnen spam
Am 08.12.2014 um 15:53 schrieb E. Braun:
Mal wieder stolpere ich über ein Problem, welches ausgestorben schien…

Gegeben ist ein frisch installiertes normales Debian Testing mit
systemd 215. Ein paar Verzeichnisse sollen beim Booten über NFS
eingebunden werden, was aber nicht immer gelingt.

Die entsprechenden Eintràge in /etc/fstab:

prost:/usr/local /usr/local nfs4 auto,nolock,tcp,noatime,nodev,async 0 0
prost:/home /home nfs4 auto,nolock,tcp,nodev,async 0 0
nfs01:/export/data08/matlab /data/matlab nfs4 auto,async 0 0


Die Meldungen über journalctl – egal, ob das Mounten gelang – lauten:

Networking[511]: Configuring network interfaces...done.
[…]
mount[582]: mount.nfs4: Failed to resolve server nfs01: Name or service not known
mount[583]: mount.nfs4: Failed to resolve server prost: No address associated with hostname
mount[585]: mount.nfs4: Failed to resolve server prost: No address associated with hostname
systemd[1]: Dependency failed for Remote File Systems.
systemd[1]: data-matlab.mount mount process exited, code=exited status2
systemd[1]: Failed to mount /data/matlab.
systemd[1]: Unit data-matlab.mount entered failed state.
systemd[1]: home.mount mount process exited, code=exited status2
systemd[1]: Failed to mount /home.
systemd[1]: Unit home.mount entered failed state.
systemd[1]: usr-local.mount mount process exited, code=exited status2
systemd[1]: Failed to mount /usr/local.
systemd[1]: Unit usr-local.mount entered failed state.

Hat jemand eine Idee, wie erreicht werden kann, daß die NFS-Mounts immer gelingen?





Das hat man nun davon, wenn man versucht Dienste parallel zu starten und
vergisst Abhàngigkeit zu beachten.

Ralph Ruthe würde sagen: "Systemd ist die größte Scheiße unter der Sonne"
https://www.youtube.com/watch?v=Gyqg8Nwe33k


Tim

Ähnliche fragen