Tabellen nach html-Export unterschiedlich breit

04/03/2010 - 21:37 von Pit Zyclade | Report spam
Hallo Kenner,

Ich habe ein Dokument über .rtf nach OOo-writer gerettet und als .odt gesichert.
Dieses Dokument verfügt über 7 gleichartig aufgebaute Tabellen, die alle gleich
breit sein sollen und eine inheltlich und formal gleiche Kopfzeile haben.

Nun exportiere ich nach .pdf und nach .htm(l).
Leider sind beim Export nach .htm(l) 2 der 7 Tabellen breiter, was ich nicht
erklàren kann. Auch ist die Aufteilung völlig sinnlos, d.h. eine Spalte
unnötigerweise zu breit, eine eigentlich breitere viel schmaler.
Ich habe deshalb die erste richtige Tabelle kopiert, eingefügt und sie mit
kopiertem Inhalt einer falschbreiten Tabelle gefüllt. Somit ist diese eine
Tabelle doppelt drin, gesichert, exportiert und ...

Auch jetzt haben die beiden, gleiche Tabellen die Überbreite und falsche
unerwünschte Spaltenbreite.

Die Ansicht der odt, die Druckansicht und pdf-Export zeigen diesen Fehler nicht.

In welchem Merkmal/welcher Einstellung soll ich denn nun noch suchen?

Gruß

Pit Zyclade
 

Lesen sie die antworten

#1 Pit Zyclade
05/03/2010 - 14:31 | Warnen spam
Pit Zyclade schrieb:
Hallo Kenner,

Ich habe ein Dokument über .rtf nach OOo-writer gerettet und als .odt
gesichert.
Dieses Dokument verfügt über 7 gleichartig aufgebaute Tabellen, die alle
gleich breit sein sollen und eine inheltlich und formal gleiche
Kopfzeile haben.

Nun exportiere ich nach .pdf und nach .htm(l).
Leider sind beim Export nach .htm(l) 2 der 7 Tabellen breiter, was ich
nicht erklàren kann. Auch ist die Aufteilung völlig sinnlos, d.h. eine
Spalte unnötigerweise zu breit, eine eigentlich breitere viel schmaler.
...



Ich konnte den Fehler selber einkreisen:
In der Tabelle sind Felder, die anscheinend leer sind, d.h. im Programm und
sogar in der Vorschau. Leider übersah ich, daß die Absatzmarke im Feld (Option
hierfür war an) nicht sichtbar war, anders als in den anderen Feldern.
Durch Fehlformatierung in den Feldern mit Einschüben rechts wird ein Teil des
Textes versteckt. Löscht man Leerstellen am Anfang oder Ende des Feldes, werden
diese Einziehungen erkennbar, das Absatzzeichen taucht auch auf. Hat man alles
so wie gewünscht korrigiert, geht der Export anschließend fehlerfrei.
Da muß man erst einmal darauf kommen!

Gruß

Pit Zyclade

Ähnliche fragen