Tabelleneinträge abgleichen & summieren

30/07/2009 - 12:54 von Holger D. | Report spam
Hallo NG,

ich habe ein Problem, wo mir einfach passende Formel fehlt. (Ich wollte das
bewusst nicht per VBA machen).

die erste Tabelle:
Objekt 1 | A1
Objekt 2 | A2
Objekt 3 | A1
...

die zweite Tabelle:
Objekt 1 | 100
Objekt 1 | 300
Objekt 3 | 50
Objekt 1 | 2000
Objekt 2 | 70

Auswertung

A1=... [und dort möchte ich nun eigentlich aus Tabelle 1 heraus suchen,
welche Objekte zu A1 gehören, die zugehörigen Objekte in Tabelle 2
wiederfinden und daraus resultierende Summe aus Spalte 2 als Ergebnis haben.]
hier: 2450

Mit =summewenn(...;sverweis();...) geht das leider nicht, da ja der sverweis
immer nur einen Wert liefert.

Hat jemand eine praktische Idee dazu?
Das wàre super nett!

Schöne Grüße,
H
 

Lesen sie die antworten

#1 Dietmar Vollmeier
30/07/2009 - 17:17 | Warnen spam
Servus Holger!

*Holger D.* schrieb am 30.07.2009 um 12:54 Uhr...
ich habe ein Problem, wo mir einfach passende Formel fehlt. (Ich wollte das
bewusst nicht per VBA machen).

die erste Tabelle:
Objekt 1 | A1
Objekt 2 | A2
Objekt 3 | A1
...

die zweite Tabelle:
Objekt 1 | 100
Objekt 1 | 300
Objekt 3 | 50
Objekt 1 | 2000
Objekt 2 | 70

Auswertung

A1=... [und dort möchte ich nun eigentlich aus Tabelle 1 heraus suchen,
welche Objekte zu A1 gehören, die zugehörigen Objekte in Tabelle 2
wiederfinden und daraus resultierende Summe aus Spalte 2 als Ergebnis haben.]
hier: 2450

[...]

Hat jemand eine praktische Idee dazu?
Das wàre super nett!



Probiere es mal mit folgender Matrix-Formel
(mit Strg+Shift+Enter abschließen)

=SUMMENPRODUKT(SUMMEWENN(Tabelle2!A1:A5;WENN(Tabelle1!B1:B3="A1";Tabelle1!A1:A3);Tabelle2!B1:B5))

HTH

und tschüss
Didi
Wozu brauchen Frauen Geld?

Sie rauchen nicht, sie trinken nicht, sie spielen nicht und
Frauen sind sie selbst.

Ähnliche fragen