Tastatur in KDE umschalten

02/03/2015 - 13:18 von Markus Grob | Report spam
Hallo zusammen

Habe auf Grund eines Tipps in einer VM Arch Linux installiert. Làuft
unterdessen alles sauber. Leider habe ich unter KDE das Problem, dass
dort die amerikanische Tastatur aktiv ist (KDE làuft auf deutsch).

In der Konsole ist das Schweizer Tastaturlayout aktiv.

Folgendes habe ich gemacht
(https://wiki.archlinux.de/title/Arc...ch_stellen):

Kontrolle von /etc/locale.conf -> LANG=de_CH.UTF-8
Kontrolle von /etc/vconsole.conf -> KEYMAP=sg-latin1

Kontrolle von /etc/X11/xorg.conf.d/20-keyboard.conf:

Section "InputClass"
Identifier "keyboard"
MatchIsKeyboard "yes"
Option "XkbLayout" "ch"
Option "XkbVariant" "nodeadkeys"
EndSection

KDE Systemeinstellungen:

Regionales -> Land: Systemeinstellung (Schweiz)
Eingabegeràte -> Hardware: Generic | Generic 105-key (Intl) PC
Belegungen: Belegungen einrichten -> ch
German(Switzerland) nodeadkeys

System schon neu gestartet. Wer weiss, welche Schraube noch gedreht
werden soll?

Gruss, Markus
 

Lesen sie die antworten

#1 Hartmut Schenke
03/03/2015 - 02:24 | Warnen spam
Am Mon, 02 Mar 2015 13:18:37 +0100
schrieb Markus Grob :

Hallo zusammen

Habe auf Grund eines Tipps in einer VM Arch Linux installiert.



Glückwunsch. :-)

Làuft
unterdessen alles sauber. Leider habe ich unter KDE das Problem, dass
dort die amerikanische Tastatur aktiv ist (KDE làuft auf deutsch).



Also KDE spricht deutsch mit dir, aber die Tasten sind qwerty statt qwertz?
Mit vm kenne ich mich nicht aus, aber könnte evtl. da etwas haken, was
einen fallback auf das "Original" (engl.) bewirkt?

In der Konsole ist das Schweizer Tastaturlayout aktiv.



Das klingt nun wieder eher nach KDE.

Mit schweizer layout hatte ich auch schon mal Schwierigkeiten. Ich habe
deswegen alles auf de_DExx gesetzt.

Folgendes habe ich gemacht
(https://wiki.archlinux.de/title/Arc...ch_stellen):

Kontrolle von /etc/locale.conf -> LANG=de_CH.UTF-8
Kontrolle von /etc/vconsole.conf -> KEYMAP=sg-latin1

Kontrolle von /etc/X11/xorg.conf.d/20-keyboard.conf:

Section "InputClass"
Identifier "keyboard"
MatchIsKeyboard "yes"
Option "XkbLayout" "ch"
Option "XkbVariant" "nodeadkeys"
EndSection



Das sieht imho gut aus. Wenngleich es bei mir
keine /etc/X11/xorg.conf.d/20-keyboard.conf gibt, sondern
eine /etc/X11/xorg.conf.d/00-keyboard.conf, die abewr auch etwas anders
lautet:

# Read and parsed by systemd-localed. It's probably wise not to edit this
file # manually too freely.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbVariant" "nodeadkeys"
EndSection


KDE Systemeinstellungen:

Regionales -> Land: Systemeinstellung (Schweiz)
Eingabegeràte -> Hardware: Generic | Generic 105-key (Intl) PC
Belegungen: Belegungen einrichten -> ch
German(Switzerland) nodeadkeys



Bei 'Belegungen einrichten' steht bei mir garnichts.

Ich glaube zwar nicht, dass es damit was zu tun haben könnte, aber hast
du /etc/locale.gen bearbeitet und locale-gen durchgeführt?

System schon neu gestartet. Wer weiss, welche Schraube noch gedreht
werden soll?



Tut mir leid, aber mehr fàllt mir dazu im Augenblick nicht ein.

Gruß
Abdul

Ähnliche fragen