Teile Konfigurator mit Excel

24/06/2009 - 17:39 von Michael | Report spam
Hallo in die Runde,

ich suche einen Ansatz, wie ich aus einer Teileliste eine Art Konfigurator
in Excel erstellen kann. Der Anwender soll auf dem ersten Blatt Spalte A in
einem Feld einen Artikel wàhlen können. Ist der Artikel ausgewàhlt, sollen
in den Spalten B,C,D... die benötigten Teile aufgelistet werden.
(Untereinander wàre auch ok.) Die Teile haben Abhànigkeiten voneinander.
Beispielsweise zu einem PC (Artikel A) gehören Monitor,ein Standfuß, ein
Kabel und eine VGAkarte. Zu einem anderen PC (Artikel B) gehört nur der
Monitor, der Standfuß und das Kabel. Die VGA-Karte ist bei diesem PC schon
on Board.

Ich habe überlegt auf dem zweiten Blatt eine Matrix der Kombinationen zu
erstellen, doch wie bekomme ich die richtige Kombination in die Spalten von
Blatt 1, wenn der Artikel ausgewàhlt wurde.

Mit der Gültigkeitsfunktion (Listen und Namen) von Excel kam ich nicht
weiter.

Da dieser Konfigurator portabel sein soll, sind Datenbanken und SQL Abfrage
etc. ausgeschlossen. Das ganze sollte innerhalb einer Exceldatei möglich
sein. Ich habe schon überlegt ein VB-Programm dafür zu schreiben. Es sollte
aber wenn möglich mit Excel-Boardmitteln möglich sein, da Excel bei uns das
bevorzugte Medium für alles Mögliche ist ;-)

Vielen Dank für jeden Tipp schon mal vorab!

VG
Michael
 

Lesen sie die antworten

#1 Claus Busch
24/06/2009 - 18:02 | Warnen spam
Hallo Michael,

Am Wed, 24 Jun 2009 17:39:54 +0200 schrieb Michael:

ich suche einen Ansatz, wie ich aus einer Teileliste eine Art Konfigurator
in Excel erstellen kann. Der Anwender soll auf dem ersten Blatt Spalte A in
einem Feld einen Artikel wàhlen können. Ist der Artikel ausgewàhlt, sollen
in den Spalten B,C,D... die benötigten Teile aufgelistet werden.
(Untereinander wàre auch ok.) Die Teile haben Abhànigkeiten voneinander.
Beispielsweise zu einem PC (Artikel A) gehören Monitor,ein Standfuß, ein
Kabel und eine VGAkarte. Zu einem anderen PC (Artikel B) gehört nur der
Monitor, der Standfuß und das Kabel. Die VGA-Karte ist bei diesem PC schon
on Board.



füge über deiner Tabelle noch 4 Zeilen ein, sodass die Überschriften
deiner Tabelle in Zeile 5 sind. Kopiere nun die Überschriftenzeile nach
Zeile 1. Selektiere A2 und gehe auf Daten => Gültigkeit => Liste und
gebe dort als Quelle den Bereich A6:A100 an (Bereich entsprechend
anpassen, ebenso in der Formel). In B2 schreibst du
=WENN(SVERWEIS($A$2;$A$6:$E$100;SPALTE();0)=0;"";SVERWEIS($A$2;$A$6:$E$100;SPALTE();0))
und ziehst die Formel so weit Zubehörspalten vorhanden sind nach rechts.
Der Kunde kann dann über die DropDown-Liste der Gültigkeit einen Artikel
auswàhlen und bekommt direkt das Zubehör angezeigt.
Wenn du mehrere Artikel gleichzeitig auswàhlen möchtest, schau dir mal
die Hilfe zum Spezialfilter an.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP1
Office 2003 SP3 / 2007 Ultimate SP2

Ähnliche fragen