Teilsumme mit zwei Bedingungen

18/02/2009 - 09:45 von light | Report spam
Hallo

Ich folgende Tabelle und möchte eine Teilsumme vom Produkt SLS200* im Markt
13)* bilden:

Produkt Stück Markt
SLS200 CL8 4 13) Elec
FLS650 1 12) Med
FLS1042 2 13) Elec
SLS200 C32 1 12) Med
SLS200 C60 2 13) Elec

dazu habe ich folgende Matrix-Formel:
{=SUMME(WENN($A$2:$A$7="SLS*";WENN($C$2:$C$7="13)*";$B$2:$B$7;0);0)}

Excel gibt mit als Resultat "0" zurück, sollte aber die Zahl 6 zurückgeben.
Ich glaube das Problem liegt an der Kombination von zwei Bediungen und dem
Platzhalter *.

Weiss jemand Rat?

Danke schon mal.



Rolf
 

Lesen sie die antworten

#1 Alexander Wolff
18/02/2009 - 10:50 | Warnen spam
Die Tastatur von light wurde wie folgt gedrückt:
Hallo

Ich folgende Tabelle und möchte eine Teilsumme vom Produkt SLS200* im
Markt 13)* bilden:

Produkt Stück Markt
SLS200 CL8 4 13) Elec
FLS650 1 12) Med
FLS1042 2 13) Elec
SLS200 C32 1 12) Med
SLS200 C60 2 13) Elec

dazu habe ich folgende Matrix-Formel:
{=SUMME(WENN($A$2:$A$7="SLS*";WENN($C$2:$C$7="13)*";$B$2:$B$7;0);0)}

Excel gibt mit als Resultat "0" zurück, sollte aber die Zahl 6
zurückgeben. Ich glaube das Problem liegt an der Kombination von zwei
Bediungen und dem Platzhalter *.



Der Platzhalter ist tatsàchlich in Matrizen nicht unkompliziert. Aber es
geht hier, dank der linksbündig vorkommenden Suchstrings, auch:

=SUMMENPRODUKT(B2:B7*(KLEIN(LINKS(A2:A7;6))="sls200")*(LINKS(C2:C7;3)="13)"))
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen