Text in Spalten vergleichen

19/12/2009 - 16:02 von Florentine Mark | Report spam
Hallo zusammen,
ich versuche seit heute morgen ein kleines Problem zu lösen, komme da jedoch
noch nicht ganz so weiter.
Vielleicht würdet ihr mir mal helfen.

Ich habe eine Tabelle mit mehreren Tabellen, die ich miteinander vergleichen
soll.

z.B.

Nr-alt nrneu
12345 54321
23456 56678

nrsystem nrsystemneu
abc-12345 ?
f23456ho ?


Ich suche also quasi nach einer Möglichkeit, zu überprüfen ob die Nr.alt
irgendwo in der Spalte nrsystem zu finden ist.
Und wenn das der Fall ist soll nrsystemneu mit nrneu ergànzt werden.

Würde das funktionieren?
Würde mich über eine Idee freuen.

Liebe grüße
die Flo...
 

Lesen sie die antworten

#1 Alexander Wolff
19/12/2009 - 19:27 | Warnen spam
Nr-alt nrneu
12345 54321
23456 56678

nrsystem nrsystemneu
abc-12345 ?
f23456ho ?



C10: =SUMMENPRODUKT((ZEILE($1:$2)*ISTZAHL(SUCHEN($A$5:$A$6;A10))))
D10: =WENN(C10;INDEX($B$5:$B$6;C10);B10)
beides an Deinen nrsystem-Eintràgen entlang kopieren

A5:A6 und 1:2 sind Deine Nr-alt-Eintràge bzw. ihr Umfang 1:N
A10: ist der nrsystem-Eintrag
(B10: und B5:B6 sind Deine entspr. Nebenspalten)

Bitte die Bereiche auf Deine Tabellen anpassen: Falls z.B. A2:A999, dann im
gleichen Zuge $1:$998
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen