Text in Zelle Suchen und in anderer Zelle ausgeben

25/02/2008 - 11:01 von Sebastian | Report spam
Hallo zusammen!

Habe ein kleines Problem.
Dies Zellen einer Spalte enthalten Daten folgenden Aufbaus:
14:15 15:40 16:30 17:58 (+35) oder aber auch 14:18 15:43 (+43Ž) 16:46
17:05
Von Interesse ist für mich aber nur die Klammer.
Nun soll in der nàchsten Spalte im ersten Fall "(+35)" stehen oder
besser "+35" und im zweiten Fall ebenso "(+43Ž) oder "+43".

Vielen Dank für die Hilfe!
Gruß Sebastian
 

Lesen sie die antworten

#1 Christian Kaiser
25/02/2008 - 11:38 | Warnen spam
Hallo Sebastian

wenn es eine Formellösung sein darf

=WENN(ANZAHL(FINDEN("(";A1));TEIL(A1;FINDEN("(";A1)+1;3);"")
in A1 steht der Text

Ergebinis
ohne Klammer

mit Klammer
=WENN(ANZAHL(FINDEN("(";A1));TEIL(A1;FINDEN("(";A1);5);"")

und falls die Anzahl der Zeichen bei der Vorwahl varieren sollte

=WENN(ANZAHL(FINDEN("(";A1));TEIL(A1;FINDEN("(";A1)+1;FINDEN(")";A1)-FINDEN("(";A1)-1);"")




Feedback nicht vergessen
Gruß Chris



"Sebastian" wrote:

Hallo zusammen!

Habe ein kleines Problem.
Dies Zellen einer Spalte enthalten Daten folgenden Aufbaus:
14:15 15:40 16:30 17:58 (+35) oder aber auch 14:18 15:43 (+43´) 16:46
17:05
Von Interesse ist für mich aber nur die Klammer.
Nun soll in der nàchsten Spalte im ersten Fall "(+35)" stehen oder
besser "+35" und im zweiten Fall ebenso "(+43´) oder "+43".

Vielen Dank für die Hilfe!
Gruß Sebastian

Ähnliche fragen