Textfragmente vergleichen

28/01/2008 - 17:02 von Johannes Marquart | Report spam
Hallo NG,

ich habe ein kleines Problem und hoffe, jemand kann mir helfen.

Excel 2003, WinXP
Ich habe eine Liste von Strings, die ich auf gleiche Anteile prüfen und
schließlich aggregieren möchte. z.B.

stadt bochum
stadt hannover
unsere stadt
stadtgarten

Diese Phrasen sollen unter dem String "stadt" aggregiert und gezàhlt
werden. Diese Aggregations-Strings bestimme ich manuell und gebe sie in
einer separaten Zelle aus.

Bisher nutze ich die Funktion
=SUMMENPRODUKT(($C$2:$C$100)*($A$2:$A$100>=$D3))

In A stehen die zu durchsuchenden Phrasen
In C sind Prozentzahlen gespeichert, die zusammengezàhlt werden sollen,
wenn der String in A enthalten ist.
D3 ist die Phrase, die in A enthalten sein soll, um die Zàhlung anzustoßen.

Problem ist, dass in A auch ein einzelnes "R" gezàhlt wird, wenn in D
z.B. "Stadt" steht.

Gibt es eine separate Text-Vergleichs-Funktion, die ich noch zusàtzlich
einschachteln könnte?

Vielen Dank schonmal,
Hannes
 

Lesen sie die antworten

#1 Alexander Wolff
28/01/2008 - 17:44 | Warnen spam
Wie aggregiert man denn Text? Ich hoffe, ich verstehe soweit richtig:

Um die Aufkommen von D3: "stadt" zu zàhlen:

=SUMMENPRODUKT(--ISTZAHL(FINDEN(D3;A2:A100))) case-sensitiv
=SUMMENPRODUKT(--ISTZAHL(SUCHEN(D3;A2:A100))) nicht "

Ergànze das um %-Zahlen mit *(C2:C100)

Deine >= Fragestellung habe ich damit nun nicht beantwortet.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen