Thinkpad X31 und CF-Card-Reader

08/09/2008 - 10:52 von Gernot Brunner | Report spam
Ich habe auf meinem Thinkpad X31 Debian Etch installiert, zuerst mit
Kernel 2.6.18. Da hatte der CF-Card-Reader auf Anhieb funktioniert, wenn
auch nicht immer.
(Manchmal tat sich einfach nichts, wenn ich eine beschriebene CF-Card
eingelegt habe, manchmal wurde das Medium einfach gemountet wie vom
USB-Stick gewohnt.)

Dann habe ich auf Kernel 2.6.24 upgedatet, und seither werden eingelegte
CF-Karten gar nicht mehr gemountet.

Auf http://www.thinkwiki.org/wiki/Category:X31 habe ich mich umgesehen.
http://www.thinkwiki.org/wiki/CF_Card_slot sagt, zustàndig für den
Reader sei das PCMCIA-Modul.

Wie gehe ich nun vor, um den richtigen Treiber für das Geràt zu
installieren? Muss ich nun einen neuen Kernel installieren oder gar
kompilieren?

Ihr seht, ich bin nicht gerade fix in Linux. Bitten icht steinigen.
Lieber wàre mir, ihr könnt mir DAU-gerecht erklàren, wie ich da vorgehen
soll.

lg Gernot
 

Lesen sie die antworten

#1 Henning Paul
08/09/2008 - 11:38 | Warnen spam
Gernot Brunner wrote:

Ich habe auf meinem Thinkpad X31 Debian Etch installiert, zuerst mit
Kernel 2.6.18. Da hatte der CF-Card-Reader auf Anhieb funktioniert,
wenn auch nicht immer.
(Manchmal tat sich einfach nichts, wenn ich eine beschriebene CF-Card
eingelegt habe, manchmal wurde das Medium einfach gemountet wie vom
USB-Stick gewohnt.)

Dann habe ich auf Kernel 2.6.24 upgedatet, und seither werden
eingelegte CF-Karten gar nicht mehr gemountet.

Auf http://www.thinkwiki.org/wiki/Category:X31 habe ich mich
umgesehen. http://www.thinkwiki.org/wiki/CF_Card_slot sagt, zustàndig
für den Reader sei das PCMCIA-Modul.

Wie gehe ich nun vor, um den richtigen Treiber für das Geràt zu
installieren? Muss ich nun einen neuen Kernel installieren oder gar
kompilieren?



Ich kann da auch nur ein paar Stichworte in den Raum stellen: CF-Karten
kennen auch einen "PCMCIA-Modus", in dem sich CF-Speicherkarten als
IDE-Controller mit fest angeschlossener Wechselplatte anmelden. Nun
werden (alle) IDE-Controller seit einiger Zeit über die libata
angesprochen und nicht mehr über die alten Treiber. Der zustàndige neue
Treiber heißt in Deinem Fall "pata_pcmcia" (der alte müsste "ide_cs"
gewesen sein). Versuche bitte mal den per Hand (mit "modprobe
pata_pcmcia" als root) zu laden und zu schauen, ob da Meldungen in der
Ausgabe von "dmesg" auftauchen. Wenn das Hotpluggen nach Laden dieses
Moduls funktioniert, mußt Du nur noch dafür sorgen, daß es automatisch
beim Boot geladen wird, da müssen Dir die Debianisten dann
weiterhelfen.

Gruß
Hennig

Ähnliche fragen