Thunderbird nimmt manche Compose-Sequenzen nicht an

17/01/2015 - 17:54 von Diedrich Ehlerding | Report spam
Hallo,

ich habe ein etwas seltsames Verhalten beobachtet. Ich kann mit Compose
diverse Sonderzeichen zusammensetzen - √, å, ſ, ¯, č usw.usf. Im uterm
funktioniert das ebenso wie in knode.

Nur Thunderbird nimmt nicht alle ... å geht, aber √ (Compose /v) nicht ...
warum nicht, was ficht ihn an? Und nein, es liegt nicht daran, dass ich
Thunderbird auf irgendeinen Iso-Zeichensatz eingestellt hàtte; er kann das
zeichen zitieren, und er nimmt es auch mit Copy+paste - nur nicht direkt
mit Compose /v.

Hat jemand da eine Idee?

Umgebung: opensuse 13.1, Thunderbird 31.3
pgp-Key (RSA) 1024/09B8C0BD
fingerprint = 2C 49 FF B2 C4 66 2D 93 6F A1 FF 10 16 59 96 F3
HTML-Mail wird ungeleſen entſorgt.
 

Lesen sie die antworten

#1 Christian Weisgerber
17/01/2015 - 21:12 | Warnen spam
On 2015-01-17, Diedrich Ehlerding wrote:

ich habe ein etwas seltsames Verhalten beobachtet. Ich kann mit Compose
diverse Sonderzeichen zusammensetzen - √, å, ſ, ¯, č usw.usf. Im uterm
funktioniert das ebenso wie in knode.

Nur Thunderbird nimmt nicht alle ... å geht, aber √ (Compose /v) nicht ...
warum nicht, was ficht ihn an?



Weil es zwei verschiedene Compose-Mechanismen sind: Bei uterm ist
es der von X11, bei Thunderbird der von GTK2. Beide bieten zwar im
Großen und Ganzen die gleichen Compose-Sequenzen an, aber ab und
zu gibt es Unterschiede.

Die X11-Sequenzen finden sich in einem systemabhàngigen Pfad in
.../X11/locale/en_US.UTF-8/Compose. Die GTK2-Sequenzen liegen
im GTK2-Source in gtk/gtkimcontextsimpleseqs.h vor.

Wer's einheitlich mag, der setzt GTK_IM_MODULE=xim im Environment
(sinnigerweise in ~/.xsession o.à.), dann verwenden auch GTK2-
Anwendungen den X11-Mechanismus statt den eigenen.

Christian "naddy" Weisgerber

Ähnliche fragen