Timeouts bei fetchmail

07/11/2007 - 10:25 von Philipp v. Thunen | Report spam
Hallo,

ich habe seit kurzem Probleme beim Abruf von Mails mit fetchmail, und zwar:

| fetchmail@pluto:~$ fetchmail -vv -S localhost/26
| [...]
| 55 messages for [...] at mail3.domainfactory.de (438420 octets).
| fetchmail: POP3> LIST 1
| fetchmail: POP3< +OK 1 4556
| fetchmail: POP3> TOP 1 99999999
| fetchmail: POP3< +OK 4556 octets
| reading message [...]@mail3.domainfactory.de:1 of 55 (4556 octets)
| About to rewrite [...]
| Trying to connect to 127.0.0.1/26...connected.
| fetchmail: SMTP< 220 pluto.pvth.net ESMTP Postfix
| fetchmail: SMTP> EHLO pluto.pvth.net
| fetchmail: SMTP< 250-pluto.pvth.net
| fetchmail: SMTP< 250-PIPELINING
| fetchmail: SMTP< 250-SIZE 100000000
| fetchmail: SMTP< 250-VRFY
| fetchmail: SMTP< 250-ETRN
| fetchmail: SMTP< 250-ENHANCEDSTATUSCODES
| fetchmail: SMTP< 250-8BITMIME
| fetchmail: SMTP< 250 DSN
| fetchmail: forwarding to localhost/26
| fetchmail: SMTP> MAIL FROM:<[...]> SIZEE56
| fetchmail: SMTP< 250 2.1.0 Ok
| fetchmail: SMTP> RCPT TO:<[...]@localhost>
| fetchmail: SMTP< 250 2.1.5 Ok
| fetchmail: SMTP> DATA
| fetchmail: SMTP< 354 End data with <CR><LF>.<CR><LF>
| #****fetchmail: timeout after 20 seconds.
| fetchmail: socket error while fetching from
| [...]@mail3.domainfactory.de
| fetchmail: 6.3.8 querying mail3.domainfactory.de (protocol POP3) at
| Wed 07 Nov 2007 10:14:34 AM CET: poll completed
| fetchmail: Query status=2 (SOCKET)
| fetchmail@pluto:~$ fetchmail -V
| This is fetchmail release 6.3.8+GSS+NTLM+SDPS+SSL+NLS+KRB5.

Meine Frage nun: Bedeutet dieser Timeout nun einen Fehler beim Abruf,
also bei der POP3-Verbindung ins Internet oder einen bei der
SMTP-Verbindung zu localhost?
Mein Mail-Provider sieht bei sich keine Probleme, aber mir ist nicht
klar, warum es Timeouts bei einer SMTP-Verbindung zu localhost geben
sollte (mailqueue ist leer, load average z. Zt. 0.00, 0.00, 0.00)?!

Dazu muss ich sagen, dass ich genau seit gestern (seitdem treten die
Probleme auch auf) meine Internetverbindung über einen VPN-Tunnel von
http://www.vtunnel.de/ führe. Aber ein traceroute weist auch nicht
unbedingt auf Verbindungsprobleme hin:

| fetchmail@pluto:~$ mtr -r -c 10 mail3.domainfactory.de
| HOST: pluto Loss% Snt Last Avg Best Wrst StDev
| 1. gw.tun1-001-126.vtunnel.de 0.0% 10 48.4 21.4 17.4 48.4 9.5
| 2. tr1.cr1.v-transit.net 0.0% 10 19.4 19.0 18.1 19.5 0.4
| 3. gi-3-1-22.gsr1.nbg.v-transit 0.0% 10 18.1 20.6 18.1 37.6 6.0
| 4. gi1-9-rt3-nbg3.core.noris.ne 0.0% 10 18.8 22.2 18.0 39.8 7.7
| 5. vl604-rt1-ffm2.core.noris.ne 0.0% 10 110.8 31.4 20.5 110.8 28.1
| 6. ??? 100.0 10 0.0 0.0 0.0 0.0 0.0
| 7. GigE-0-1.gate.ispgateway.de 10.0% 10 28.7 46.3 27.5 181.5 50.7
| 8. halo.ispgateway.de 0.0% 10 27.5 30.6 25.9 52.8 8.3

TIA,
-Philipp
 

Lesen sie die antworten

#1 Juergen P. Meier
07/11/2007 - 10:33 | Warnen spam
Philipp v. Thunen :
| Trying to connect to 127.0.0.1/26...connected.
| fetchmail: SMTP< 354 End data with <CR><LF>.<CR><LF>
| #****fetchmail: timeout after 20 seconds.
| fetchmail: socket error while fetching from
| [...]@mail3.domainfactory.de

Meine Frage nun: Bedeutet dieser Timeout nun einen Fehler beim Abruf,
also bei der POP3-Verbindung ins Internet oder einen bei der
SMTP-Verbindung zu localhost?



Was sagt das Log vom lokal laufenden Postfix?

Ähnliche fragen