TLS-Probleme mit Samba und OpenLdap

30/04/2009 - 12:52 von Thomas Günther | Report spam
Hallo,

nach einem Posting auf linux.debian.user.german versuche ich es mal
hier noch:

Ich versuche hier seit einiger Zeit eine bis dato bewàhrte Kombination
von Samba, OpenLdap und TLS als PDC aufzusetzen.
Der Ldap-Server und der Samba-Server laufen beide auf je einem
Debian-(Lenny)-System.

PAM auf dem Samba-Server funktioniert mit tls, es gibt (offensichtlich)
keine Probleme. Die Anmeldung auf der Konsole des Samba-Servers mit im
Ldap gespeicherten Benutzern funktioniert. Ein Wechsel zwischen
Benutzern ist ebenso möglich.

Die smbldap-tools laufen auch mit tls.

Wenn ich den Samba-Server starte, bekomme ich auf dem LDAP-Server
folgende Fehlermeldung:
TLS: can't accept: The peer did not send any certificate..
und im Endeffekt kann ich mich nicht (z.B. per smbclient) zum
Samba-Server verbinden. Ich bekomme noch nichtmal eine Passwortabfrage.
Ohne tls làuft's.

Ich habe gelesen, dass Samba die Konfiguration von /etc/ldap/ldap.conf
nutzt. Stimmt das? Laut 'man ldap.conf' sind die Optionen
TLS_CERT <filename> und TLS_KEY <filename> aber "user-only options",
können also nicht in der /etc/ldap/ldap.conf angegeben werden bzw.
werden dort ignoriert. Ich hab sie trotzdem mal drin stehen.

Ich hàng' da jedenfalls schon eine Weile fest und komm' nicht weiter.
Hat jemand eine Idee oder einen Tipp?


Gruss
Thomas
 

Lesen sie die antworten

#1 Michael Ströder
30/04/2009 - 14:31 | Warnen spam
Thomas Günther wrote:

Wenn ich den Samba-Server starte, bekomme ich auf dem LDAP-Server
folgende Fehlermeldung:
TLS: can't accept: The peer did not send any certificate..



Du hast wahrscheinlich TLS so eingestellt, dass Client-Zertifikate
zwingend erforderlich sind. Prüfe mal den Wert für TLSVerifyClient in
der slapd.conf.

Ciao, Michael.

Ähnliche fragen