ToolboxBitmap für Steuerelement

23/02/2010 - 17:26 von Jakob Brunner, Luzern Switzerland | Report spam
Salü zàme
Mein Benutzersteueerelement funktioniert bis an die Umschönheit, dass das
Icon in der Toolbox oder bei der Verwndung in der Form nicht angezeigt wird.
In der Literatur wird angegeben, man müsste nur dieses
ToolboxBitmap-Attribut angeben.
[ToolboxBitmap(typeof(MyControl), "MyControlBitmap")] ganz einfach soll
dies gehen!

Ich habe aber im Internet gelesen, dass auch andere Anwender mit dieser
Anzeige ihre Mühe hatten. Weiss ind er Zwischenzeit jemand, wie dies zum
Laufen gebracht werden kann??

Gruss
Jakob
 

Lesen sie die antworten

#1 Frank Dzaebel
23/02/2010 - 20:13 | Warnen spam
Hallo Jakob,

Ich habe aber im Internet gelesen, dass auch andere Anwender mit dieser
Anzeige ihre Mühe hatten. Weiss ind er Zwischenzeit jemand, wie dies zum
Laufen gebracht werden kann??



Ja, das geht schon immer (definitiv), nur es wurden
meistens nicht die Hinweise beachtet (bzw. diese standen
zum Teil früher auch noch nicht in der Doku ;-)

[Gewusst wie: Bereitstellen einer Toolboxbitmap für ein Steuerelement]
http://msdn.microsoft.com/de-de/lib...1wc0a.aspx

1) Beachte den dortigen Hinweis:
"Die Bitmap wird in der Toolbox für automatisch
generierte Steuerelemente und Komponenten
nicht angezeigt. Damit die Bitmap angezeigt
wird, müssen Sie das Steuerelement über das
Dialogfeld Toolboxelemente auswàhlen neu laden."

Praktisch bedeutet das normal, dass man auf das
UserControl in der ToolBox: [Entf] drückt und dann
über rechte Maus/"Elemente auswàhlen" das
Exe der Applikation einbindet. Dann klappt
es auch mit dem eigenen Icon fürs UserControl
in der ToolBox.

2) Es muss mindest ein Bildtyp mit der Größe: 16 x 16
im Icon enthalten sein. (Es können auch mehrere drin sein).

[19.2.5 Bereitstellen einer Toolbox-Bitmap]
http://openbook.galileocomputing.de...17aecc74a9


ciao Frank
Dipl.Inf. Frank Dzaebel [MCP/MVP C#]
http://Dzaebel.NET

Ähnliche fragen