Forums Neueste Beiträge
 

TransferText funktioniert nicht mehr mit Win 7 64 bit

23/12/2013 - 16:53 von Max | Report spam
Hallo NG,

ich habe kürzlich von xp 32 bit auf Win 7 64 bit gewechselt.
Ich habe in meiner A03-DB ein Makro,
mit dem Datensàtze einer Abfrage in eine Textdatei exportiert werden.
Unter xp funktionierte dieses super,
es wurde automatisch das ; als Trennzeichen verwendet.
Unter Win 7 kommt nun die Fehlermeldung:
Die exportierten Daten stimmen nicht mit dem in der Datei SCHEMA.INI beschriebenen Format überein. (Fehler 3438)
Argumente meines Makros:
2; ; Übergabe PC-Adress; D:\Eigene-Dateien-d5\PCA\Adressimport.txt; Ja; ;
Ich habe bereits die Angabe der Trennzeichen in der Lànderkennung geprüft.
Dort ist ein Semikolon eingetragen. Bei Dezimal das Komma.
Exportiere ich von Hand, klappt es genauso wenig.
Stelle ich das Exportformat MS Word Merge (.txt) ein,
klappt es zwar, jedoch fehlt das Trennzeichen, welches ich zum Import wiederum dringend benötige.
Habe schon lange probiert und bin ziemlich verzweifelt.
Weiß jemand eine Lösung?
Gruß
Max
 

Lesen sie die antworten

#1 Ulrich Möller
27/12/2013 - 19:47 | Warnen spam
Am 23.12.2013 16:53, schrieb Max:
Hallo NG,

ich habe kürzlich von xp 32 bit auf Win 7 64 bit gewechselt.
Ich habe in meiner A03-DB ein Makro,
mit dem Datensàtze einer Abfrage in eine Textdatei exportiert werden.
Unter xp funktionierte dieses super,
es wurde automatisch das ; als Trennzeichen verwendet.
Unter Win 7 kommt nun die Fehlermeldung:
Die exportierten Daten stimmen nicht mit dem in der Datei SCHEMA.INI beschriebenen Format überein. (Fehler 3438)
Argumente meines Makros:
2; ; Übergabe PC-Adress; D:\Eigene-Dateien-d5\PCA\Adressimport.txt; Ja; ;
Ich habe bereits die Angabe der Trennzeichen in der Lànderkennung geprüft.
Dort ist ein Semikolon eingetragen. Bei Dezimal das Komma.
Exportiere ich von Hand, klappt es genauso wenig.
Stelle ich das Exportformat MS Word Merge (.txt) ein,
klappt es zwar, jedoch fehlt das Trennzeichen, welches ich zum Import wiederum dringend benötige.
Habe schon lange probiert und bin ziemlich verzweifelt.
Weiß jemand eine Lösung?
Gruß
Max


Hallo Max,

siehe hier http://support.microsoft.com/kb/508589/de

Das ist zwar für ACC97, sollte aber immer noch gültig sein.
Erstelle einfach explizit eine neue Exportspezifikationsdatei mit dem
Assistenten und überprüfe diese im Editor. Anschließend im TransferText
Kommando diese dann mit angeben, anstatt die internen Formate zu benutzen.

Ulrich

Ähnliche fragen