Forums Neueste Beiträge
 

TS2008 + XP: SSO etc.

06/10/2009 - 14:11 von Wolfgang Krietsch | Report spam
Hi!

Bei der Einführung einer kleinen TS-Umgebung stoßen wir an
verschiedenen Stellen auf Probleme; vielleicht kann hier ja jemand
helfen.

Umgebung: XP-Clients, 2 W2K8 Terminalserver, die letztlich zu einer
Farm mit Sessionbroker und/oder NLB zusammengeschlossen werden sollen;
dies alles in einem W2K3-AD. Ingesamt sollen auf den beiden TS nur 4 -
5 Anwendungen laufen mit 50 Usern, wobei davon vermutlich nur sehr
wenige gleichzeitig darauf arbeiten.

RemoteApps per RDP-Dateien sollen verwendet werden.

1. Single-Sign-On

*Eigentlich* hàtte ich ja gedacht, dass das per default einfach so
geht: alle Clients und Server sind Mitglied der gleichen
(W2K3-AD-)Domàne, alle haben sich lieb, SSO ist kein Problem.
Pustekuchen. Davon ab, dass ich nicht verstehe, welche
sicherheitsrelevanten Überlegungen von MS sich dahinter verbergen (?),
habe ich das SSO Problem hiermit:

<http://www.ravenreport.com/blog/pos...r.aspx>

gelöst.

Aber da steht halt unten auch, dass SSO mit XP und einer *Farm*
generell nicht funktioniert.

Ist das tatsàchlich so? Oder gibt's da doch einen Trick?

2. Gedenkminute

Der Start einer Anwendung per RDP dauert, wenn noch keine Sitzung
besteht, ziemlich lange. Liegt das einfach daran, dass ein
Benutzerprofil geladen werden muss etc. und man muss damit leben, oder
kann man das grundsàtzlich irgendwie beschleunigen? Ja, ich weiß, die
Frage ist etwas vage formuliert ...

3. Zugriff auf einzelne Server der Farm

Wenn die Server zu einer Farm zusammengeschlossen sind ist es
anscheinend nicht mehr möglich, per RDP gezeilt auf einzelne Server
zuzugreifen, da der Sessionbroker dass dann umleitet. Ist das wirklich
so und nicht zu àndern (bzw. nur mit einer zweiten Netzwerkkarte in
den Servern=), oder haben wir uns da irgendwo vertüddelt?

So, ich würde mich freuen, wenn mich da jemand etwas erleuchten könnte
... danke schonmal.


Grüße

woffi
 

Lesen sie die antworten

#1 kd
06/10/2009 - 21:17 | Warnen spam
Hi,

an der Baustelle bin ich auch gerade dran.
2. Gedenkminute stört mich auch, ahbe aber noch keine Lösung.

3. Versuch mal mstsc /admin; das sollte dich zum richten Server verbinden,
wenn man sich unter Admin anmeldet.
Eine andere Lösung habe ich bisher leider nicht gefunden. Ich wollte z.B.
auf einem Server der Farm nur eine Anwendung installieren ( wegen Lizenzen)
man kommt als normaler User aber nur auf irgendeinem der Farm raus.
Übringens sind die TS-Server auf W2K8 R2 seit Ende August.

Gruss, KD



"Wolfgang Krietsch" wrote:

Hi!

Bei der Einführung einer kleinen TS-Umgebung stoßen wir an
verschiedenen Stellen auf Probleme; vielleicht kann hier ja jemand
helfen.

Umgebung: XP-Clients, 2 W2K8 Terminalserver, die letztlich zu einer
Farm mit Sessionbroker und/oder NLB zusammengeschlossen werden sollen;
dies alles in einem W2K3-AD. Ingesamt sollen auf den beiden TS nur 4 -
5 Anwendungen laufen mit 50 Usern, wobei davon vermutlich nur sehr
wenige gleichzeitig darauf arbeiten.

RemoteApps per RDP-Dateien sollen verwendet werden.

1. Single-Sign-On

*Eigentlich* hàtte ich ja gedacht, dass das per default einfach so
geht: alle Clients und Server sind Mitglied der gleichen
(W2K3-AD-)Domàne, alle haben sich lieb, SSO ist kein Problem.
Pustekuchen. Davon ab, dass ich nicht verstehe, welche
sicherheitsrelevanten Überlegungen von MS sich dahinter verbergen (?),
habe ich das SSO Problem hiermit:

<http://www.ravenreport.com/blog/pos...r.aspx>

gelöst.

Aber da steht halt unten auch, dass SSO mit XP und einer *Farm*
generell nicht funktioniert.

Ist das tatsàchlich so? Oder gibt's da doch einen Trick?

2. Gedenkminute

Der Start einer Anwendung per RDP dauert, wenn noch keine Sitzung
besteht, ziemlich lange. Liegt das einfach daran, dass ein
Benutzerprofil geladen werden muss etc. und man muss damit leben, oder
kann man das grundsàtzlich irgendwie beschleunigen? Ja, ich weiß, die
Frage ist etwas vage formuliert ...

3. Zugriff auf einzelne Server der Farm

Wenn die Server zu einer Farm zusammengeschlossen sind ist es
anscheinend nicht mehr möglich, per RDP gezeilt auf einzelne Server
zuzugreifen, da der Sessionbroker dass dann umleitet. Ist das wirklich
so und nicht zu àndern (bzw. nur mit einer zweiten Netzwerkkarte in
den Servern=), oder haben wir uns da irgendwo vertüddelt?

So, ich würde mich freuen, wenn mich da jemand etwas erleuchten könnte
danke schonmal.


Grüße

woffi

Ähnliche fragen