Forums Neueste Beiträge
 

Über mehrere Bereiche verteilte Namen zählen

23/10/2008 - 19:05 von J. Müller | Report spam
Hallo und Guten Abend!

Mein Problem ist folgendes: In einer Tabelle sind in verschiedenen Bereichen
(A3:A14, A19:A30 usw.) Namen von Personen eingetragen. Zum Teil auch
mehrfach, so kommt z. B. Herr Meyer mehrmals vor.

In einer Zeile unterhalb der Tabelle soll nun die Summe der Namen angezeigt
werden, wobei Dopplungen - wie bei Herrn Meyer - nur einmal gezàhlt werden
sollen.

Nun habe ich allerlei schon probiert - bis hin zur Matrixformel (die mit den
geschweiften Klammern):

={SUMME(WENN(A3:A14<>"";1/ZÄHLENWENN(A3:A14;A3:A14);0))}

Gezàhlt wird aber nur die Anzahl A3:A14 - A19 bis A30 natürlich nicht.

Meine Frage: Wie muss die Formel erweitert werden, damit auch getrennte
Bereiche mitgezàhlt werden? Gibt es eine Obergrenze für die Anzahl der
getrennten Bereiche?

Hoffentlich habe ich mich einigermaßen verstàndlich ausgedrückt...

Danke schon jetzt für jede Hilfe!

Jan.
 

Lesen sie die antworten

#1 Eberhard Funke
23/10/2008 - 19:55 | Warnen spam
Am Thu, 23 Oct 2008 19:05:49 +0200 schrieb J. Müller:

Hallo und Guten Abend!

Mein Problem ist folgendes: In einer Tabelle sind in verschiedenen Bereichen
(A3:A14, A19:A30 usw.) Namen von Personen eingetragen. Zum Teil auch
mehrfach, so kommt z. B. Herr Meyer mehrmals vor.

In einer Zeile unterhalb der Tabelle soll nun die Summe der Namen angezeigt
werden, wobei Dopplungen - wie bei Herrn Meyer - nur einmal gezàhlt werden
sollen.


Meine Frage: Wie muss die Formel erweitert werden, damit auch getrennte
Bereiche mitgezàhlt werden? Gibt es eine Obergrenze für die Anzahl der
getrennten Bereiche?



Hallo Jan,

A32: =SUMMENPRODUKT((A1:A30<>"")/(ZÄHLENWENN(A1:A30;A1:A30)+(A1:A30= "")))

Die Frage nach der Obergrenze kann ich leider nicht beantworten.

Mit freundlichen Grüssen Eberhard
XP home XL 2000
Eberhard(punkt)W(punkt)Funke(at)t-online.de

Ähnliche fragen