Überhitzung nach längerer Betriebszeit

15/05/2010 - 12:34 von Rainer Knaepper | Report spam
Moin moin,

ein Bekannter betreibt einen kleinen Server mit einem AM2-Athlon

model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
stepping : 1
model : 107

(mehr weiß ich im Moment nicht)

Das ist nun schon die zweite CPU von der Sorte, einmal wurde schon
getauscht, die nach einigen Monaten fehlerfreien Betriebs plötzlich
meint, überhitzen und sich abschalten zu müssen.

Làuft da die Wàrmeleitpaste aus? Ist das ein Serienfehler? Der
Prozessorkühler ist angeblich korrekt montiert und hat sich auch nicht
losgerappelt.

Rainer

Bildung will man _real_ auch nicht, sonst tàte man nicht versuchen,
mit Studiengebühren weitere Einnahmen zu generieren, offenbar setzt
man in der Wirtschaftspolitik auf die reichhaltig in Deutschland
vorhandenen Bodenschàtze. (Oliver Bartels in de.sci.electronics)
 

Lesen sie die antworten

#1 Rainer Meier
16/05/2010 - 13:18 | Warnen spam
Hallo,

On 15.05.2010 12:34, Rainer Knaepper wrote:

Moin moin,

ein Bekannter betreibt einen kleinen Server mit einem AM2-Athlon

model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
stepping : 1
model : 107

(mehr weiß ich im Moment nicht)



Ich hab' hier einen Server mit einem Athlon 64 X2 4850e und auch sonst schon so
einige PCs/Workstations mit AMD CPU zusammengebaut.


Das ist nun schon die zweite CPU von der Sorte, einmal wurde schon
getauscht, die nach einigen Monaten fehlerfreien Betriebs plötzlich
meint, überhitzen und sich abschalten zu müssen.



Wie àusserte sich das Problem?
Ich persönlich hatte erst einmal einen Athlon 64 der zu heiss wurde. Bei diesem
hat das Board Akkustische Warnsignale ausgegeben als er so ca. 70°C erreicht
hatte. Der Grund war ein nicht eben aufliegender CPU-Kühler. Normalerweise ist
daran eine falsche Kühler-Montage schuld. In meinem Fall war es aber tatsàchlich
die CPU selber. Der Heat-Spreader war konkave geformt (gut zu sehen mit einem
Haarlineal). Nachdem ich den Kühler entfernt hatte konnte man schon mit blossem
Auge erkennen, dass die am Kühler befestigte Paste nicht überall Kontakt zum
Heat-Spreader der CPU hatte.


Làuft da die Wàrmeleitpaste aus? Ist das ein Serienfehler? Der
Prozessorkühler ist angeblich korrekt montiert und hat sich auch nicht
losgerappelt.



Eigentlich sollte da gar nichts auslaufen können. Zumindest wenn der
Boxed-Lüfter verwendet wird. Hier liegt üblicherweise keine Paste bei sondern
einim kalten Zustand zàhes Wàremeleitpad ist schon auf dem Kühler aufgebracht.
Vielleicht hat dein Bekannter das Pad entfernt/ersetzt und verwendet zu viel
oder gar keine Wàrmeleitpaste.

Leider schreibst du nicht welches Betriebssystem dein bekannter benutzt. Bei mir
ist es Gentoo Linux. Hier ist es wichtig auch die Stromspar-Mechanismen zu
verwenden (sollte bei aktuellen Distributionen zum Standard gehören). Bei mir
verwende ich cpufreqd mit folgender Rule:

[Rule]
name¬ Rule
profile=On Demand Full Scale
cpu_interval=ANY:0-100
[/Rule]

[Profile]
name=On Demand Full Scale
minfreq=0%
maxfreq0%
policy=ondemand
[/Profile]

Ebenfalls wichtig, dass im Kernel das CPU Frequency Scaling aktiviert ist.
Ob CPU frequency scaling korrekt funktioniert làsst sich auch über eineinfaches
'cat /proc/cpuinfo' herausfinden. Neben diversen Infos zur CPU erscheint dort
auch die aktuelle Taktrate unter "cpu MHz". Bei meinem 4850e sind das 1000MHz
wenn die Kiste idle ist.

In keinem Fall dürfte die CPU aber ohne Power-Management einfach so überhitzen.
Denn unter stundenlanger Vollast dürfte das eben auch nicht geschehen.

Möglich wàre auch, dass die Kiste eventuell in einer relativ staubigen Umgebung
steht. Dann kann sich schon mal innerhalb weniger Wochen/Monate eine
Staubschicht zwischen Lüfter und CPU-Kühler bilden welche den Luftfluss so
behindert, dass der Kühler nicht mehr effizient arbeiten kann. Einfach mal
nachsehen und einen eventuellen Staub-Teppich entfernen.
Kann auch so àhnlich aussehen:
<http://dau-alarm.de/pictures/hardwa..._k.jpg>
<http://dau-alarm.de/pictures/hardwa..._k.jpg>

Letzteres stammt sogar von mir bzw. einem Kundensystem. Ist zwar eine
Grafikkarte aber auch hier überhitzte diese permanent. Der Staub liess sich auch
kaum mehr entfernen weil dieser dank Teer (Kunde raucht in der Bude) den Staub
zu einer klebrigen Masse verwandelte :S.


Gruss
Rainer

Ähnliche fragen