Ubuntu - grub2 - Xserver - Grafik - Tastatur - Maus

22/01/2012 - 00:49 von Paul-Wilhelm Hermsen | Report spam
Problem bei Neueinrichtung von Ubuntu auf einem System mit ATI-Grafikkarte:
Ubuntu-Desktop LTS 10.04 ließ sich zwar installieren, doch nach dem
Start fror das System regelmàßig in der grafischen Oberflàche (Gnome)
nach wenigen Sekunden bis Minuten ein. Die Grafikkarte verursacht
vermutlich das Problem. Vermutlich sind fast alle Besitzer einer
ATI-Grafikkarte davon betroffen.

Abhilfe:
Einrichten des vesa-Grafiktreibers!
Wenn das Grub-Bootmenü nicht erscheint, weil nur 1 OS installiert ist,
beim Booten die Shift-Taste gedrückt halten, damit es erscheint.
(Bei mir lag noch ein kleiner Sonderfall vor. Ich musste zuerst die
STRG-Taste zusammen mit der ESC-Taste drücken, bis das System beepte und
dann auf die alleinige Shift-Taste wechseln. Erst daraufhin erschien das
Grub-Bootmenü.)
Dann den Wiederherstellungsmodus wàhlen und bestàtigen.
Im darauf erscheinenden Menü failsaveX wàhlen. Die darauf erscheinenden
Meldungen können ignoriert werden, indem einfach weiter geklickt wird.
Danach startet der XServer ohne Absturzprobleme. In der grafischen
Oberflàche das Terminal öffnen und mit "sudo -i" die
Administratorenebene betreten. In das Verzeichnis /etc/X11 wechseln, "cd
/etc/X11".
Der Befehl "ls" zeigt dort eine xorg.conf.failsave. Vermutlich ist keine
xorg.conf vorhanden, da sie nicht mehr unbedingt für einen
funktionierenden Xserver benötigt wird. Jetzt mit dem Befehl "cp
xorg.conf.failsave xorg.conf" die xorg.conf.failsave zur auf diese Weise
neu erstellten, xorg.conf kopieren. Hierdurch wird der
vesa-Grafiktreiber, der bei failsafeX der Standard ist, für den normalen
Start "festgeklopft".
Danach das System neu booten, und der Spuk hat ein Ende.
Ist zwar etwas umstàndlich, aber anders bekommt man wegen der Hànger
keine Konfigurationsànderung hin.
 

Lesen sie die antworten

#1 Patrick Rudin
22/01/2012 - 01:54 | Warnen spam
Paul-Wilhelm Hermsen wrote:
Die Grafikkarte verursacht vermutlich das Problem. Vermutlich sind fast
alle Besitzer einer ATI-Grafikkarte davon betroffen.



Welche konkrete Graphikkarte ist das denn bei Dir und welcher Treiber
ganz genau wurde denn da benutzt?


Gruss

Patrick

Ähnliche fragen