Ubuntu ohne Systemd

07/11/2016 - 08:44 von Oliver Sch | Report spam
Hallo zusammen,

ich hab hier das Phànomen, dass mit einem Ubuntu 16 und LVM die
Deinstallation von Systemd zu einem hàngenden Boot führt.

Nach mehreren Versuchen habe ich jetzt 2 Hypothesen:

1) mit einem LV geht es, mit mehreren nicht.

2) Es geht mit mehreren LVs, aber die müssen eine bestimmte Größe haben
und/oder nur in einem Krypto-Container geht es mit mehren LVs.

Hat jemand von euch àhnliche Erfahrungen gemacht?

Ich sehe, dass das Root-LV gemounted wird, ich sehe dazu
Ext4-Meldungen. Dann hàngt es. Meldungen werde ich noch nachliefern.

Mit einem Rettungs-System kann ich die Volumes aktivieren und es làuft.
Mit "init=/bin/bash" kann ich dagegen mit einem "vgscan; vgchange -ay"
ein hàngenden vgchange erzeugen, der nie zurückkehrt.

Das mag aber auch an Ubuntu im Allgemeinen liegen und hat womöglich mit
dem Problem gar nichts zu tun.

Ich hab Udev mal auf Debug geschaltet, sehe aber, dass er dort alle
Devices anlegt - das bestàtigt meine Vermutung, dass das hàngende
vgchange ein anderes Problem ist.

Mein Ziel wàre, dass Problem einerseits an den Upstream zu liefern und
andererseits làngerfristig Debian und Ubuntu auf Installationsmedien
ohne Systemd auszuliefern, sprich ein automatischer ISO-Erzeuger +
Skript, was man Inline verwenden kann, um Systemd loszuwerden.

D.h. man würde ein Server- und ein Desktop-Iso bei Ubuntu haben, was
Systemd als Init nicht anzieht. Bei Debian wàren es dann das
Netzwerk-ISO und Standard-ISO.

Ich wollte mich aber nicht unbedingt vom Upstream trennen, indem ein
voller Mirror/Fork gemacht wird. Nur die Standard-Installation sollte
halt neu sein.

mfg
Oli

Man darf ruhig intelligent sein, man muss sich nur zu helfen wissen
 

Lesen sie die antworten

#1 Oliver Sch
07/11/2016 - 10:09 | Warnen spam
On Mon, 7 Nov 2016 08:44:44 +0100
"Oliver " wrote:

Ich sehe, dass das Root-LV gemounted wird, ich sehe dazu
Ext4-Meldungen. Dann hàngt es. Meldungen werde ich noch nachliefern.



Hier die Meldungen.

http://oschad.de/screenshot_ubuntu_hangs.jpg

Ich hab 3 LVs gemacht, root, var, tmp. Alle sind 8 GB groß, mit Ext4.

Ich gehe davon aus, dass ich Größenprobleme ausschließen kann.

Mit Systemd làuft es, mit Upstart hàngt es.

Installation von Upstart mit:

apt-get update; apt-get install upstart-sysv; reboot

Nur mit einem großen Root-LV geht das.

mfg
Oli

Man darf ruhig intelligent sein, man muss sich nur zu helfen wissen

Ähnliche fragen