Uhrzeit zw. 22 u. 24 Uhr - Excel 2002

11/08/2009 - 11:40 von Bernd Muley | Report spam
Hallo an Alle!

Ich möchte bei Zellen einer bestimmten Spalte feststellen, ob die Uhrzeit
zwischen >" Uhr und <$ Uhr liegt - und in anderen Zellen entsprechend
einen Wert eintragen

die Zellen sind benutzerdefiniert als - TT.MM.JJJJ hh:mm - formatiert
dies brauche ich so, da auch das Datum mit eine Rolle spielt

hoffe, es kann mir jemand helfen!!

Gruß und danke vorab - Bernd Muley
 

Lesen sie die antworten

#1 Bernhard Sander
11/08/2009 - 12:01 | Warnen spam
Hallo Bernd,

Ich möchte bei Zellen einer bestimmten Spalte feststellen, ob die
Uhrzeit zwischen >" Uhr und <$ Uhr liegt - und in anderen Zellen
entsprechend einen Wert eintragen

die Zellen sind benutzerdefiniert als - TT.MM.JJJJ hh:mm - formatiert
dies brauche ich so, da auch das Datum mit eine Rolle spielt


Zunàchst ein bisschen Hintergrund:
Datums- und Zeitangaben speichert Excel als Zahlen, wobei die Stellen vor dem
Komma das Datum angeben und die Stellen nach dem Komma für die Zeit stehen.
Sàmtliche Anteile einer Datums-/Zeit-Angabe können mit den Funktionen Jahr(..),
Monat(), Tag(), Stunde(), Minute(), Sekunde() abgefragt werden. Die liefern die
entsprechende Zahl zurück.
Die Uhrzeit 24:00 gibt es in dem Sinne nicht in Excel, das ist der Folgetag 0:00.

Damit ergibt sich für den Vergleich (Annahme: in A1 steht der zu prüfende
Datums/Zeitwert)
=WENN(ODER(STUNDE(A1) >= 22; A1=GANZZAHL(A1)); "22-24Uhr";"vor 22Uhr")

Gruß
Bernhard Sander

Ähnliche fragen