Umlaute nur auf einer tty

27/07/2008 - 19:23 von Andreas Kohlbach | Report spam
Seit irgendeinem Update habe ich keine Umlaute mehr auf der Textkonsole
(tty, im Xterm schon, aber andere Baustelle).

Nach diesem (oder einem anderen zu der Zeit etwa) werden auch .bashrc
bzw. .bash_profile ignoriert.

Meine lokales sehen derzeit so aus:

LANG=C
LANGUAGE=us
LC_CTYPE="en_CA.iso88591"
LC_NUMERIC="en_CA.iso88591"
LC_TIME="en_CA.iso88591"
LC_COLLATE="en_CA.iso88591"
LC_MONETARY="en_CA.iso88591"
LC_MESSAGES="en_CA.iso88591"
LC_PAPER="en_CA.iso88591"
LC_NAME="en_CA.iso88591"
LC_ADDRESS="en_CA.iso88591"
LC_TELEPHONE="en_CA.iso88591"
LC_MEASUREMENT="en_CA.iso88591"
LC_IDENTIFICATION="en_CA.iso88591"
LC_ALL=en_CA.iso88591

So waren die IIRC immer schon, als ich noch Umlaute hatte, sollte auch
so sein (Kanada).

Ich kann ausserdem nichts ausser LANG und LANGUAGE aendern (mittels
export auf der Bash), alles andere wird ignoriert, auch wenn locale -a
etwa "de_DE" anzeigt, was ich zum Testen nahm.

Eben faellt mir auf, dass ich offenbar nur auf der tty4 Umlaute haben
kann. Warum gerade dort, und wo ich suchen muss (in der inittab fand ich
nichts Auffaelliges), weiss ich nicht, auf den anderen nicht (jeweils
der selbe User ueberall eingeloggt).

Debian/Lenny

dpkg-reconfigure locales wird ignoriert, also was ich dort als default
Locale eintrage.

Ich wuerde vermuten, ich habe versehntlich ein wichtiges Paket
geloescht. Aber welches?
Andreas (PGP Key available on public key servers)
32. Ummm... Didn't you say you turned it off?
 

Lesen sie die antworten

#1 Friedemann Stoyan
28/07/2008 - 06:53 | Warnen spam
Andreas Kohlbach wrote:
Seit irgendeinem Update habe ich keine Umlaute mehr auf der Textkonsole
(tty, im Xterm schon, aber andere Baustelle).



Schaue Dir mal an, wie Deine lokalen Console-Fonts konfiguriert sind. Ich lade
in '/etc/console-tools/config':

# Eurosupport
SCREEN_FONT=lat9u-16

Damit gibts Umlaute + € in der Konsole.


mfg Friedemann

Ähnliche fragen