UMTS mit ppp Problem

16/10/2008 - 00:10 von Sven Mönnich | Report spam
Hallo,

ich habe Debian/Etch und möchte nun per UMTS ins Internet.
Die Pcmcia-Karte wird erkannt, ist über /dev/ttyS1 ansprechbar und wàhlt
sich mit "pon umts" auch ein, jedenfalls wird ppp0 aktiviert und bekommt
auch eine ip.

evocom:/etc/ppp/peers# cat umts
user "alice"
connect "/usr/sbin/chat -v -f /etc/chatscripts/umts"
/dev/ttyS1
460800
modem
usepeerdns
defaultroute
noauth
noipdefault
persist
demand
idle 300

evocom:/etc/chatscripts# cat umts
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
REPORT CONNECT
TIMEOUT 10
"" "AT&F"
OK "ATZ"
OK "ATEOV1&D2$C1S0+IFC=2,2"
OK "ATE1"
OK AT+CGDCONT=1,"IP","internet.partner1"
OK "ATDT*99***1#"
CONNECT C



ppp0 Protokoll:Punkt-zu-Punkt Verbindung
inet Adresse:10.64.64.64 P-z-P:10.112.112.112
Maske:255.255.255.255
UP PUNKTZUPUNKT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlànge:3
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Die IP 10.112.112.112 làsst sich nicht anpingen genausowenig wie google.
woran könnte das liegen ?

evocom:/etc/chatscripts# route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use
Iface
10.112.112.112 * 255.255.255.255 UH 0 0 0 ppp0
172.16.0.0 * 255.240.0.0 U 0 0 0 eth0
default 172.17.1.1 0.0.0.0 UG 0 0 0 eth0


Für jeden hinweis dankbar

-Sven-
 

Lesen sie die antworten

#1 Mike Schulz
16/10/2008 - 17:24 | Warnen spam
N'abend.

Steht in dem Script wirklich:
AT+CGDCONT=1,"IP","internet.partner1"

Bei EPlus muss als APN folgendes stehen: internet.eplus.de

Gruß


Sven Mönnich schrieb:
Hallo,

ich habe Debian/Etch und möchte nun per UMTS ins Internet.
Die Pcmcia-Karte wird erkannt, ist über /dev/ttyS1 ansprechbar und wàhlt
sich mit "pon umts" auch ein, jedenfalls wird ppp0 aktiviert und bekommt
auch eine ip.

evocom:/etc/ppp/peers# cat umts
user "alice"
connect "/usr/sbin/chat -v -f /etc/chatscripts/umts"
/dev/ttyS1
460800
modem
usepeerdns
defaultroute
noauth
noipdefault
persist
demand
idle 300

evocom:/etc/chatscripts# cat umts
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
REPORT CONNECT
TIMEOUT 10
"" "AT&F"
OK "ATZ"
OK "ATEOV1&D2$C1S0+IFC=2,2"
OK "ATE1"
OK AT+CGDCONT=1,"IP","internet.partner1"
OK "ATDT*99***1#"
CONNECT C



ppp0 Protokoll:Punkt-zu-Punkt Verbindung
inet Adresse:10.64.64.64 P-z-P:10.112.112.112
Maske:255.255.255.255
UP PUNKTZUPUNKT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlànge:3
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Die IP 10.112.112.112 làsst sich nicht anpingen genausowenig wie google.
woran könnte das liegen ?

evocom:/etc/chatscripts# route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use
Iface
10.112.112.112 * 255.255.255.255 UH 0 0 0
ppp0
172.16.0.0 * 255.240.0.0 U 0 0 0
eth0
default 172.17.1.1 0.0.0.0 UG 0 0 0
eth0


Für jeden hinweis dankbar

-Sven-




Mike
ID = 0x239772EC FP = 8B35 0E61 8BDD 9825 42EC 01A9 57AE 6995 2397 72EC

Ähnliche fragen