Ungleiche zählen mit 2 Bedingungen?

14/03/2010 - 15:38 von Peter Schürer | Report spam
Hallo Zusammen,

XL2002.

Wir haben folgenden Aufbau:

Spalte A B E
01.03.10 1 TZE
01.03.10 1 TZE
01.03.10 1 TZE
01.03.10 1 TZE
01.03.10 1 QWH 27
01.03.10 1 QWH 27
01.03.10 2 11HBG
01.03.10 2 11HBG
01.03.10 2 RRR
01.03.10 2 HHGB
01.03.10 2 TZE

Ich brauche jetzt eine Formel, die zàhlt wie viele unterschiedliche
Werte in Spalte E bei gleichen Werten in A und B stehen.
Ergebnis:
01.03.10 1 2
01.03.10 2 4

Mit =SUMMENPRODUKT((Datum=$A4)*(Band=$B4)*(Model>0)) erhalte ich die Anzahl.
Ich habe schon alles versucht, entweder Fehler oder Anzahl.

Danke und Gruß
Peter
 

Lesen sie die antworten

#1 Claus Busch
14/03/2010 - 17:01 | Warnen spam
Hallo Peter,

Am Sun, 14 Mar 2010 15:38:59 +0100 schrieb Peter Schürer:

Wir haben folgenden Aufbau:

Spalte A B E
01.03.10 1 TZE
01.03.10 1 TZE
01.03.10 1 TZE
01.03.10 1 TZE
01.03.10 1 QWH 27
01.03.10 1 QWH 27
01.03.10 2 11HBG
01.03.10 2 11HBG
01.03.10 2 RRR
01.03.10 2 HHGB
01.03.10 2 TZE

Ich brauche jetzt eine Formel, die zàhlt wie viele unterschiedliche
Werte in Spalte E bei gleichen Werten in A und B stehen.



probiers mal so (Formel zàhlt beim ersten Vorkommen des Bandes, hier also
Zeile 2 und 8, falls du Überschriften hast. Formel gehört dann in Zelle
F2):
=WENN(ZÄHLENWENN($B$2:B2;B2)=1;SUMME((VERGLEICH($A$2:$A$12&$B$2:$B$12&$E$2:$E$12;$A$2:$A$12&$B$2:$B$12&$E$2:$E$12;0)=ZEILE($1:$11)*($A$2:$A$12¢)*($B$2:$B$12²)*($E$2:$E$12<>""))*1);"")
und mit STRG+Shift+Enter abschließen.
Eventuell Bezüge anpassen.
Du könntest es auch mit einer Pivot-Tabelle lösen. Datum und Modell in
Zeilenbereich, Band in Spaltenbereich und Modell nochmals in Wertebereich.


Mit freundlichen Grüssen
Claus Busch
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen