unmet dependencies

26/02/2010 - 17:05 von Ch. Hanisch | Report spam
Hallo,
ich wollte mein grml-System aktualisieren.

apt-get clean all
apt-get update
apt-get dist-upgrade
...
You might want to run apt-get -f install to correct these
The following packages have unmet dependencies:
emacs22: Depends: emacs22-bin-common (".3+1-1) but 22.3+1-1.2 is installed
libhtml-parser-perl: Depends: perl (>=5.10.1-5) but 5.10.0-22 is installed
Depends: perlapi-5.10.1
E. Unmet.dependencies Try using -f

Ein
apt-get -f install
konnte das Problem nicht lösen.

Was muß ich tun, damit das "dist-upgrade" funktioniert?

Gruß
Ch. Hanisch
 

Lesen sie die antworten

#1 Sven Joachim
26/02/2010 - 17:18 | Warnen spam
Am 26.02.2010 um 17:05 schrieb Ch. Hanisch:

Hallo,
ich wollte mein grml-System aktualisieren.

apt-get clean all
apt-get update
apt-get dist-upgrade
...
You might want to run apt-get -f install to correct these
The following packages have unmet dependencies:
emacs22: Depends: emacs22-bin-common (".3+1-1) but 22.3+1-1.2 is installed
libhtml-parser-perl: Depends: perl (>=5.10.1-5) but 5.10.0-22 is installed
Depends: perlapi-5.10.1
E. Unmet.dependencies Try using -f

Ein
apt-get -f install
konnte das Problem nicht lösen.

Was muß ich tun, damit das "dist-upgrade" funktioniert?



Zuerst mal die sources.list posten und das, was
»apt-cache policy emacs22 perl« ausgibt.

Sven

Ähnliche fragen