unterbericht verhält sich merkwürdig

06/04/2009 - 13:47 von Marc Derndorff | Report spam
Hallo, liebe NG!

Ich nutze AC03 in kleinem Netz und habe ein Problem mit einem neuen Bericht,
den ich erstellen muss. Der Bericht soll ein vorgegebenes Aussehen haben.
Hier der Aufbau (vereinfacht):

BB TTTTTTTTTTTT
BB
BB UU UU TTT
BB UU UU TTT
BB UU UU TTT
BB
BB TTTTTTTTTTTT

B ist dabei ein Bild (JPG) mit einem Schriftzug, der hochkant steht.
T ist Text bzw. Zahlen.
U ist ein mehrspaltiger Unterbericht, bei dem sowohl die Anzahl der Zeilen
als auch die Lànge des Textes pro Element variabel sein muss. Im
Unterbericht findet sich nur der Detailbereich mit einemn einzigen Textfeld,
dessen Eigenschaft "vergrößerbar" auf JA steht. Der Unterbericht ist als
mehrspaltig gekennzeichnet (über Seite einrichten). Das Steuerlement, das
den Unterbericht im Hauptbericht repràsentiert, ist auf "vergrößerbar" NEIN
eingestellt, damit ggf. überzàhlige Inhalte einfach nicht angezeigt werden.
Der Hauptbericht besteht nur aus einer einzigen Seite (ist ein Preisschild).

Jetzt treten allerlei merkwürdige Probleme auf.

1. Vor der eigentlichen Seite kommt eine leere Seite. Wenn ich das Bild oder
den Unterbericht entferne, tritt das nicht auf. Seitenrànder habe ich
eigentlich mehrfach geprüft. Auf der zweiten Seite ist auch der korrekte
Bericht komplett zu sehen. Das Problem tritt auch auf, wenn ich das Bild
sehr verkleinere oder die restlichen Element zusammenschiebe und den Bericht
verkleinere.
2. Obwohl bei dem Unterbericht die Eigenschaften "vergrößerbar" und
"verkleinerbar" auf NEIN stehen, dehnt sich der Unterbericht nach unten über
den Rest der Seite aus.

Gescheiterte Lösungsversuche: Ich kann den Unterbericht nicht durch einzelne
Textfelder im Hauptbericht ersetzen, die ich dann z.B. per VBA füllen würde,
weil die Textfelder ihre Größe àndern können müssen. Statt dem Bild wàre ein
Schriftzug hochkant denkbar, aber mit einem Textfeld und der Eigenschaft
"vertikal" dreht sich der Text genau in die falsche Richtung (nàmlich im
Uhrzeigersinn, ich bràuchte aber gegen den Uhrzeigersinn).

Irgendwelche Ideen?

Vielen Dank im voraus

Gruß

Marc
 

Lesen sie die antworten

#1 Thomas Möller
06/04/2009 - 15:01 | Warnen spam
Hallo Marc,

Marc Derndorff schrieb:
Ich nutze AC03 in kleinem Netz und habe ein Problem mit einem neuen Bericht,
den ich erstellen muss. Der Bericht soll ein vorgegebenes Aussehen haben.
Hier der Aufbau (vereinfacht):

BB TTTTTTTTTTTT
BB
BB UU UU TTT
BB UU UU TTT
BB UU UU TTT
BB
BB TTTTTTTTTTTT

B ist dabei ein Bild (JPG) mit einem Schriftzug, der hochkant steht.
T ist Text bzw. Zahlen.
U ist ein mehrspaltiger Unterbericht, bei dem sowohl die Anzahl der Zeilen
als auch die Lànge des Textes pro Element variabel sein muss. Im
Unterbericht findet sich nur der Detailbereich mit einemn einzigen Textfeld,
dessen Eigenschaft "vergrößerbar" auf JA steht. Der Unterbericht ist als
mehrspaltig gekennzeichnet (über Seite einrichten). Das Steuerlement, das
den Unterbericht im Hauptbericht repràsentiert, ist auf "vergrößerbar" NEIN
eingestellt, damit ggf. überzàhlige Inhalte einfach nicht angezeigt werden.
Der Hauptbericht besteht nur aus einer einzigen Seite (ist ein Preisschild).

Jetzt treten allerlei merkwürdige Probleme auf.

1. Vor der eigentlichen Seite kommt eine leere Seite. Wenn ich das Bild oder
den Unterbericht entferne, tritt das nicht auf. Seitenrànder habe ich
eigentlich mehrfach geprüft. Auf der zweiten Seite ist auch der korrekte
Bericht komplett zu sehen. Das Problem tritt auch auf, wenn ich das Bild
sehr verkleinere oder die restlichen Element zusammenschiebe und den Bericht
verkleinere.
2. Obwohl bei dem Unterbericht die Eigenschaften "vergrößerbar" und
"verkleinerbar" auf NEIN stehen, dehnt sich der Unterbericht nach unten über
den Rest der Seite aus.

Gescheiterte Lösungsversuche: Ich kann den Unterbericht nicht durch einzelne
Textfelder im Hauptbericht ersetzen, die ich dann z.B. per VBA füllen würde,
weil die Textfelder ihre Größe àndern können müssen. Statt dem Bild wàre ein
Schriftzug hochkant denkbar, aber mit einem Textfeld und der Eigenschaft
"vertikal" dreht sich der Text genau in die falsche Richtung (nàmlich im
Uhrzeigersinn, ich bràuchte aber gegen den Uhrzeigersinn).



schau mal, ob Du mit der Lösung von Stephen Lebans weiter kommst:
http://www.lebans.com/rotatetext.htm
(Link in einer Zeile)


Thomas

Homepage: www.Team-Moeller.de

Ähnliche fragen