Unterbericht wird nicht angezeigt

06/03/2008 - 17:18 von Mattes | Report spam
Hallo NGler,

ich habe vor ein paar Tagen nach einer Lösung für ein Print AddIn gefragt
(bei Access Server Client). Mittlerweile habe ich eine Lösung gefunden. Ich
habe in einer ADP eine MDB als Verweis integriert und dort Funktionen
hinterlegt, die den entsprechenden Report mit Filtern öffnet. So weit so gut.
Es funktioniert hervorragend und auch bei grossen Datenmengen sehr schnell.
Ich habe nun das Problem, dass die Sub-Reports nicht angezeigt werden. Rufe
ich die selben Reports mit den gleichen Parametern direkt in der MDB auf,
sind die Sub-Reports da!?!

Hat jemand eine Idee, wie man das beheben kann oder wo das Problem liegt?

Access 2003 ADP als Frontend
Access 2003 MDB als Report Generator
SQL 2005 als Datenbank-Backend

Vieln Dank für eure Tips
Mattes
 

Lesen sie die antworten

#1 Mattes
07/03/2008 - 09:17 | Warnen spam
"Mattes" wrote:

Hallo NGler,

ich habe vor ein paar Tagen nach einer Lösung für ein Print AddIn gefragt
(bei Access Server Client). Mittlerweile habe ich eine Lösung gefunden. Ich
habe in einer ADP eine MDB als Verweis integriert und dort Funktionen
hinterlegt, die den entsprechenden Report mit Filtern öffnet. So weit so gut.
Es funktioniert hervorragend und auch bei grossen Datenmengen sehr schnell.
Ich habe nun das Problem, dass die Sub-Reports nicht angezeigt werden. Rufe
ich die selben Reports mit den gleichen Parametern direkt in der MDB auf,
sind die Sub-Reports da!?!

Hat jemand eine Idee, wie man das beheben kann oder wo das Problem liegt?

Access 2003 ADP als Frontend
Access 2003 MDB als Report Generator
SQL 2005 als Datenbank-Backend

Vieln Dank für eure Tips
Mattes



Hab die Lösung gefunden!

Die Sub-Reports hatten als RecordSource direkt die Tabellen und waren (sind)
über entsprechende Felder verknüpft. Ich habe es nun umgestellt auf SELECT *
FROM Tabelle, und siehe da, die Daten werden angezeigt!
Ist das logisch?

Mattes

Ähnliche fragen